This discussion is archived
1 Reply Latest reply: May 2, 2012 6:03 PM by bobthesungeek76036 RSS

"clq:  (C192716) I/O error." message when trying to add a quorum device

bobthesungeek76036 Pro
Currently Being Moderated
A little bit of history: Recently our storage folks migrated us from CLARiiON LUNs to VNX LUNs on all the shared disks. At the time, the cluster booted fine. However, since all the DID device IDs changed, we no longer have a valid quorum device:

<pre>bash-3.00$ sudo clq list
d11
host2
host1
bash-3.00$ sudo cldev show d11
cldev: (C727402) Could not locate instance "11".
bash-3.00$</pre>

When I try to add another quorum device I get the error shown in the title:

<pre>bash-3.00$ sudo clq add d41
clq: (C192716) I/O error.
bash-3.00$ sudo cldev show d41

=== DID Device Instances ===

DID Device Name: /dev/did/rdsk/d41
Full Device Path: host2:/dev/rdsk/c4t5006016B46E0574Ed0
Full Device Path: host2:/dev/rdsk/c6t5006016946E0574Ed0
Full Device Path: host2:/dev/rdsk/c4t5006016246E0574Ed0
Full Device Path: host2:/dev/rdsk/c6t5006016046E0574Ed0
Full Device Path: host2:/dev/rdsk/c8t5006016346E0574Ed0
Full Device Path: host2:/dev/rdsk/c2t5006016146E0574Ed0
Full Device Path: host2:/dev/rdsk/c8t5006016A46E0574Ed0
Full Device Path: host2:/dev/rdsk/c2t5006016846E0574Ed0
Full Device Path: host1:/dev/rdsk/c2t5006016846E0574Ed0
Full Device Path: host1:/dev/rdsk/c8t5006016A46E0574Ed0
Full Device Path: host1:/dev/rdsk/c2t5006016146E0574Ed0
Full Device Path: host1:/dev/rdsk/c8t5006016346E0574Ed0
Full Device Path: host1:/dev/rdsk/c4t5006016246E0574Ed0
Full Device Path: host1:/dev/rdsk/c6t5006016046E0574Ed0
Full Device Path: host1:/dev/rdsk/c6t5006016946E0574Ed0
Full Device Path: host1:/dev/rdsk/c4t5006016B46E0574Ed0
Replication: none
default_fencing: global

bash-3.00$</pre>

Another issue we are having is that all the shared disks are showing "failed" for their status:

<pre>bash-3.00$ sudo cldev status d41

=== Cluster DID Devices ===

Device Instance Node Status
--------------- ---- ------
/dev/did/rdsk/d41 host1 Fail
host2 Fail

bash-3.00$</pre>

The old CLARiiON devices had array failover mode of 1 and the new devices have array failover mode of 4. Anyone know if that is an issue? I have MPxIO disabled in the fp.conf file.

Any assistance would be greatly appreciated.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points