This discussion is archived
2 Replies Latest reply: May 7, 2012 7:45 AM by 915739 RSS

OBIEE REPORT  GIVING NO Data for select criteria  WHEN WE GIVE A FILTER

915739 Newbie
Currently Being Moderated
Hi Gurus,

If we give a filter condition using prompts in obiee dashboard it is giving error like There is no data for selected critera.Please change parameters and try again.
Actually data is there for selected items but when we select a value in prompt it is giving above error.With out filter it is giving all values.but when we select a particular value to filter out is giving like this.

Pls any one suggest me. where should i check for this.

Edited by: 912736 on May 4, 2012 4:52 PM
  • 1. Re: OBIEE REPORT  GIVING NO Data for select criteria  WHEN WE GIVE A FILTER
    David_T Guru
    Currently Being Moderated
    The obvious general answer is that the value that is being used to filter the column has no match. Try doing this:

    1) On the column that will receive the dashboard prompt presentation variable, click on the fx button.

    2) Apply the TRIMBOTH function and for the char, use a space (single quote, space, single quote).

    3) Click the filter button on this modified column and set it equal to the PV.

    Sometimes the column contains a leading or trailing space in it. No problem if you just display all values and hard to tell why filtering for a value known to be in the table results in "no results." Often the extra space is the culprit. Try it.
  • 2. Re: OBIEE REPORT  GIVING NO Data for select criteria  WHEN WE GIVE A FILTER
    915739 Newbie
    Currently Being Moderated
    Hi,

    But still it is giving same error.Iam using combined request using union as set operator.
    Is there any problem with combined request?
    Though it is having data when we select particular value it is throwing error.

    Could you pls suggest me here




    Regards,
    siva

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points