7 Replies Latest reply: May 8, 2012 8:38 AM by user897654321 RSS

    Unable to assign imported ISO to Server Pool


      I have imported my ISO file with success to my ISO repository. I've done everythng according to the OVM documentation to do so.

      Only problem is that It's mentionned that you have to "assign" this ISO to you server pool by clicking ASSIGN.

      I don't know what's going on but I have not such button anywhere!

      Can anyone help me out?

        • 1. Re: Unable to assign imported ISO to Server Pool
          Having Exactly the same problem. I'm trying to get a VM of Oracle Linux 6 Ver1 to work.
          I used an http server and brought the OracleLinux-R6-U1-Server-x86_64-dvd.iso into my repository.

          When I make a virtual machine, and select the iso in the storage options, it creates a VM very fast.
          But always, always the virtual machine WILL NOT start.
          Something is not connected or listed in somewhere.

          All my problems are associated with using Xen PVM for a domain type.
          Evidently, this is hard to get working when using a shared NFS storage system?

          When I edit the VM to use Xen HVM it starts right up, but stops by itself after about 30 seconds.

          One thing about this program; it will allow you to configure incorrect groups of settings with create errors.
          It needs to be worked on to NOT ALLOW the user to select something if it's not specifically geared toward a specific outcome.

          I need to chat with one of the programmers on this project.

          Edited by: user6192829 on Dec 13, 2011 11:48 AM

          Edited by: user6192829 on Dec 13, 2011 11:53 AM

          Edited by: user6192829 on Dec 13, 2011 11:56 AM
          • 2. Re: Unable to assign imported ISO to Server Pool
            I have same problem that MArt's post, I can not find the "ASSIGN" button to assign imported ISO toVM.
            I can assigen the ISO by "edit" of VM, but it have to shutdown the VM and it is not smart.
            • 3. Re: Unable to assign imported ISO to Server Pool
              Does anybody shed a lite at the problem ?
              • 4. Re: Unable to assign imported ISO to Server Pool
                If I understand the problem correctly, you have successfully imported an iso into your repository, and want to mount it to a running VM and not have to restart the VM.

                When I edit the VM (I'm using build 150. It may have changed with 227 or 240), I select the Disks tab, and check the ISO I want to mount. You must then click the Disk Ordering tab or the Disk change won't "take". Then click OK.

                This appears only to work for PVM machines. With an HVM machine, I get errors. However, I can do the 'xm block-attach' manually on the OracleVM host console.

                Command the manager used (which failed "Path closed or removed during hotplug add"):
                xm block-attach 0004fb0000060000ddc33a3c6c757e80 file:/OVS/Repositories/0004fb0000030000c06cc3dbdeff0d4b/ISOs/0004fb0000150000158ee262673031f4.iso, xvdb:cdrom, r

                Command I used (which worked):
                xm block-attach 0004fb0000060000ddc33a3c6c757e80 file:/OVS/Repositories/0004fb0000030000c06cc3dbdeff0d4b/ISOs/0004fb0000150000158ee262673031f4.iso, xvdc, r

                I think the manager is trying to mount the ISO on the /cdrom directory, but without the PVM drivers, it's failing to complete the mount. Once it has failed, it can never work because the manager doesn't increment the xvd index (note I used xvdc instead of xvdb. xvdb was in use by then by the aborted attach). You can "fix" this with a xm block-detach <domain id> xvdb if you want the CD to mount as /dev/sdb specifically. Then you can issue the block-attach with xvdb instead of xvdb:cdrom.

                As to the other poster who couldn't get the ISO to boot, there is a tab in the Edit VM dialog for boot order. If the CDROM is not in the list, it will not boot to it. If the machine is configured correctly, then there must be an error rasied. If you can't find it in the Manager, check /var/log/ovs-agent.log on the host.

                Please provide some error messages and software versions and we can be more specific.
                • 5. Re: Unable to assign imported ISO to Server Pool
                  I have the same problem.
                  The problem is not like you describe Dan.

                  The "page" in question is in VM Manager 3.0.3:
                  "Home" -> "Server Pools" -> "Repositories" (Tab) -> "ISOs" (Tab)

                  After importing an ISO, it must (according to the documentation) be assigned to a server pool.
                  It is described as (after importing the ISO-file):
                  1) select the ISO file
                  2) Click assign

                  Now the problem is that there is no visible assign-button or link anywhere.
                  Why is it missing? Where can it be found?

                  Thanks in advance.

                  It seems not to matter. You don't have to assign anything.
                  I was unable to use the ISO-file, and thus thought that I was missing the "assign".
                  The real problem however was that I was trying to start a virtual machine of type PVM on the ISO. That is not possible (for some obscure reason).
                  I found out how to enable VTx on my server and it was running :-)
                  The alternative (when running virtual machines in PVM mode) is to mount the ISO and make it accessible via http.
                  Refer to:
                  http://docs.oracle.com/cd/E26996_01/e18549/BABIAEIJ.html (under "Xen PVM")

                  Edited by: user1430186 on 2012-04-26 01:40
                  • 6. Re: Unable to assign imported ISO to Server Pool
                    Abhishek Anand
                    you dont have to assign anywhere (for 3.0.3)
                    once u imported the iso just create the Virtual Machine on same Repository and select the iso on Select Disks and ISOs tab on Setup Disk Order 1st should be your virtual Disk n 2nd your iso and on last tab Boot Options move first disk then CDROM.
                    if you are using any old Virtual Disk then make CDROM first and Disk second on Boot Options....after installation
                    change the order again.

                    Abhishek Anand
                    • 7. Re: Unable to assign imported ISO to Server Pool
                      Just to reiterate, ISO's that are imported into a repository can not be made available on PVM's (at least from my experience).

                      To boot off the ISO you need to mount the ISO somewhere that is http or ftp accessible, change to a Network boot in the Boot Order tab, and assign the correct URL to that mounted ISO on the Network Boot Path.