0 Replies Latest reply on May 11, 2012 1:07 PM by 935878

    Server had a GSS-API erro

      Hi everyone .. I have ran into a weird one.


      #ssh serverC
      Server had a GSS-API error; the connection will close (458752/2):
      No credentials were supplied, or the credentials were unavailable or inaccessible
      No such file or directory

      But when the user does an ssh from
      ServerB to ServerA works
      ServerA to ServerB or ServerC works
      ServerC to ServerB or ServerA works

      Only Server B to Server C give this error.

      Now on ServerB if I run klist I see the following:

      /usr/bin/klist -f
      Ticket cache: FILE:/tmp/krb5cc_7141
      Default principal: myuser@mydomain.corp

      Valid starting Expires Service principal
      05/08/12 11:19:12 05/08/12 21:19:11 krbtgt/mydomain
      Flags: IA
      05/08/12 11:19:12 05/08/12 21:19:11 host/ServerB
      Flags: A
      05/08/12 11:19:14 05/08/12 21:19:11 host/ServerC@

      After doing some testing .. ServerC is the only one that doesnt drop from the klist output.
      All of the other ones dont have that issue.

      When I run kdestroy .. that clears it up and ssh works without any issues.

      For now I set up the .profile to run a kdestroy when logging in.

      But I would like to figure out what is causing this issue.

      Any ideas? I think it is pam related?
      But I am not sure what I am looking for.


      Edited by: 932875 on May 11, 2012 6:07 AM