This discussion is archived
4 Replies Latest reply: May 11, 2012 9:28 AM by 874727 RSS

Installation Error - Windows Process Activation Service (WAS) and WWW Publi

874727 Newbie
Currently Being Moderated
Hi all,

I am a newbie to UPK..

Just tried installing UPK Developer Server + Client on my local machine, and hit upon the following error that I have no idea of !!


---------------------------
Service status check
---------------------------
Setup cannot determine if Windows Process Activation Service (WAS) and World Wide Web Publishing are installed on the computer.
Confirm that Windows Process Activation Service (WAS) and World Wide Web Publishing are installed and running on the computer.

Please select another configuration.
---------------------------
OK
---------------------------

I am using Win 7 Ultimate.. 32 bit.. ran the Installer with Administrator privileges already !!

Any help from you, in case you have the solution, would be highly appreciated.. :)

Besties..
Sahil
  • 1. Re: Installation Error - Windows Process Activation Service (WAS) and WWW Publi
    user390060 Newbie
    Currently Being Moderated
    Hi Sahil,

    Couple of things here - The server component on UPK can only be installed on Windows Server 2003 or 2008 - so it seems as if you are choosing the incorrect installation option when running the setup. There are normally a few options when you run the setup for UPK - these include the following:
    1. Developer Client
    2. Developer Server
    3. Developer Server and Client
    4. Developer Single User
    5. Knowledge Center

    You should be selecting option 4 - Developer Single user. This will install all binaries required (including the database) to your local machine. This option is not used as a multi-user environment, but rather for sole use on your PC/laptop. If you intend on installing on a multi-user environment, you will need to review the Tech Specs for UPK to ensure that you meet the Hardware and Software requirements.

    The errors you are receiving about WAS is related to IIS. You need to ensure that the role for IIS is installed on your machine - The webserver component of UPK utilises IIS.

    Hope this all helps.

    Regards,
    Greig
  • 2. Re: Installation Error - Windows Process Activation Service (WAS) and WWW Publi
    874727 Newbie
    Currently Being Moderated
    Thanks, Greig. Yes, it was about IIS. I installed IIS7 and it all seems to have gone through without any hitch.

    Just another one. I didn't use Windows Server, but rather just on Win XP. It seems to have gotten through OK. I am still trying to work out how to access the UPK Server though.
    In case it helps, I chose the third option of Server + Client when at the time of installation.

    Sahil
  • 3. Re: Installation Error - Windows Process Activation Service (WAS) and WWW Publi
    user390060 Newbie
    Currently Being Moderated
    Hi Sahil,

    Good news!
    Yes it probably would have worked on XP - it is just not certifed (you wouldn't be able to get support unless you installed on a certified O/S).

    Have you accessed your UPK server yet? I saw another thread that you posted asking what the URL was - and you seemed to have come right with that one...
    Anything else you may want assistance with on the install etc?

    Regards,
    Greig
  • 4. Re: Installation Error - Windows Process Activation Service (WAS) and WWW Publi
    874727 Newbie
    Currently Being Moderated
    Hi Greig,

    Thanks for your message.

    Yes, it's just a trial I am doing right now, so not too concerned about support to be honest !! ;)

    No, I couldn't work out how to access the server yet. Can you help me with that please ?
    I am assuming that the server is installed correctly already, since I installed a Multi-user version, and I have been able to create connection profiles for the Library easily. I guess I just need to put in more work towards the admin of UPK server to work out those parts! :)


    Sahil

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points