0 Replies Latest reply on May 17, 2012 8:19 PM by chrdei

    Unsupported VC socket option


      I'm currently working on a new subversion interface. The goal is that the Oracle DB can read the content of a previously defined svn repository. The java library SVNKit is responsible for the communication.

      The implementation worked fine. Executing the script within a SQL*Plus session will work, but if I want to execute the same script in Apex 4.1 the connection fails. The trace file points me to an error while establishing the connection to the repository.

      Error Message:
      Error while connecting to the repository
      svn: E210003: Unsupported VC socket option

      The error code E210003 was generated by the java library. I do not understand why it works within the SQL Developer but not in the Apex SQL Workshop. The SELECT is every time the same:
      SELECT pac_svn_repository.getHeadRevision()
      FROM dual;

      I use the following environment
      - Oracle on SunOS 5.10
      - SVN-Server: Over WebDAV (http) or SVN (I have tried both)
      - The Java Permissions are set correctly
      - PL/SQL Embedded Gateway

      Does anyone know what's wrong?

      Edited by: chrdei on 17.05.2012 13:18: Webserver Information added