1 2 Previous Next 27 Replies Latest reply: Jun 18, 2012 3:47 AM by Prabodh RSS

    XDB question

    lily
      I install oracle 11g r2 in windows 2003 sever and ative the apex 3.x
      The URL http://localhost:8080/apex/apex_admin can be open in pc web Internet Explorer
      but when I open it by mobile Explorer,it need to input the username and password by 'XDB'
      How can I do it
        • 1. Re: XDB question
          Prabodh
          Did you try searching the forum for this error before posting? Its always better to search before posting a query.

          Take a look at Re: XDB username and passwrod

          Regards,
          • 2. Re: XDB question
            Zulqarnain
            Hi

            I am copying/pasting from http://docs.oracle.com/cd/B28359_01/install.111/b32006/postcfg.htm

            In a new installation or when upgrading the database, you configure the embedded PL/SQL gateway by running the configuration script apxconf.sql. Running this script enables you to configure the port for Oracle XML DB HTTP server and to specify a password for the Application Express ADMIN account. Then, you unlock the ANONYMOUS account.

            To configure the embedded PL/SQL gateway:

            Change your working directory to ORACLE_BASE\ORACLE_HOME\apex or whatever convention used to indicate the Oracle home.

            Start SQL*Plus and connect to the database where Oracle Application Express is installed as SYS. For example:

            DRIVE_LETTER:\> sqlplus /nolog
            SQL> CONNECT SYS as SYSDBA
            Enter password: SYS_password
            Run apxconf.sql as shown in the following example:

            @apxconf
            When prompted, enter a password for the Application Express Admin account.

            Be sure to make a note of the password you enter. You will use this password to log in to Oracle Application Express Administration Services.

            When prompted, enter the port for the Oracle XML DB HTTP server. The default port number is 8080.

            Enter the following statement to unlock the ANONYMOUS account:

            ALTER USER ANONYMOUS ACCOUNT UNLOCK;


            ---
            Zulqarnain
            MaxApex Hosting
            http://www.maxapex.com
            • 3. Re: XDB question
              lily
              now,I can open the url http://127.0.0.1:8080/apex/f?p=100

              but, on my apple iphoe 4s,the home page can be opened,but when I input the username and password ,it turns
              the requested url /f was not found on this sever

              the url is right in my Android phone
              • 4. Re: XDB question
                Prabodh
                If it is the same application that you run on Android as well as iPhone 4s then the reason may be related to the phone browser. Chrome vs Safari?

                Regards,
                • 5. Re: XDB question
                  lily
                  Now,the same url is ok in pc's Explorer
                  but in iphone 3 or 4s,it's ok
                  in nokia or other phone,it display XDB and need to input the username and password
                  • 6. Re: XDB question
                    lily
                    I want to when I use mobile phone open the url ,the apex can't display the XDB info,and don't let user input the username and password
                    • 7. Re: XDB question
                      Prabodh
                      Hi,
                      I do not have all those smart phones :-)

                      The issue appears to be related to the phone browsers or their settings. Things like JavaScript enabling, security setting ,etc.

                      Incidentally Nokia Symbian phones also use Safari, though perhaps not the same versions as iPhones.

                      XDB user/password prompt is usually an installation wide thing, not application or device specific.

                      Regards,
                      • 8. Re: XDB question
                        lily
                        Now,I only want to don't display the XDB info ,How can I set it?
                        • 9. Re: XDB question
                          Prabodh
                          You cannot set it to "not display".

                          Getting this message is usually an indication of the setup being incomplete or incorrect.

                          Have you unlocked the APEX_PUBLIC_USER and ANONYMOUS accounts?

                          You will find many threads on this forum on how to address the XDB login from popping up.

                          What is baffling is that you do not get it all the time. Did you by any chance save the password in the browser after the first time you were prompted for the XDB password on the desktop and the phones where it works?

                          Regards,
                          • 10. Re: XDB question
                            lily
                            sorry,I have execute the sql:
                            ALTER USER ANONYMOUS ACCOUNT UNLOCK;
                            but the XDB is still display
                            • 11. Re: XDB question
                              lily
                              The XDB server 's port is also 8080?
                              and the same to apex's default?
                              If I modify the XDB port ,it can ok ?
                              • 12. Re: XDB question
                                Prabodh
                                Its the same thing. Apex uses the XDB HTTP Port.

                                Have you unlocked APEX_PUBLIC_USER? The same way use unlocked ANONYMOUS?

                                Regards,
                                • 13. Re: XDB question
                                  938465
                                  run apxdimg.sql script one directory up from apex folder.
                                  • 14. Re: XDB question
                                    lily
                                    FF
                                    1 2 Previous Next