9 Replies Latest reply: May 24, 2012 9:09 AM by 663057 RSS

    JVM is -Xms 1024m -Xmx5120m

    663057
      Hi Experts,

      as my earlier thread related to out of memory error-

      Re: Planning URL frequently unavailable

      I checked it's already set

      Xms 1024m
      Xmx 5120m

      Please suggest if we have any other option. Physical Memory consumption of box was between 98-99.8%

      Regards
      Kumar
        • 1. Re: JVM is -Xms 1024m -Xmx5120m
          Rowdy
          I don't think you can use 5GB max on Planning process, even 64-bit server and software wouldn't allow that. I will be surprised if the process starts with this setting. when I tried 3 GB my Planning process did not even start. I would recommend both Xms & Xmx set to 2048m and see how is doing.

          Can you give us more information about your infrastructure like, Planning server tech specs. Like John suggested in other thread some times forms performance will depend on design and data form optimized design techniques and essbase cache settings.

          Good Luck.
          • 2. Re: JVM is -Xms 1024m -Xmx5120m
            JohnGoodwin
            Just out of interest why do you think it couldn't be set to that on 64bit? I have seen 6GB at one client.

            Cheers

            John
            http://john-goodwin.blogspot.com/
            • 3. Re: JVM is -Xms 1024m -Xmx5120m
              Rowdy
              It didn't let me do that, may be I am wrong. when I tried 3 GB the process it did not even start. May be it was because there was no RAM left on the server.

              Sorry if I am wrong.
              • 4. Re: JVM is -Xms 1024m -Xmx5120m
                JohnGoodwin
                You may have needed to add an extra parameter e.g. –XXcompressedRefs:size=32GB
                Though I am not saying the answer is just to increase the maximum JVM, form design is important.

                Cheers

                John
                http://john-goodwin.blogspot.com/
                • 5. Re: JVM is -Xms 1024m -Xmx5120m
                  663057
                  Thanks John & User7876731.

                  As John is suggesting it can be possible upto 6GB.
                  You may have needed to add an extra parameter e.g. –XXcompressedRefs:size=32GB
                  where to set this parameter and how?
                  Though I am not saying the answer is just to increase the maximum JVM, form design is important.
                  Agree

                  Regards
                  Kumar

                  Edited by: Kumar 1 on May 23, 2012 7:38 AM
                  • 6. Re: JVM is -Xms 1024m -Xmx5120m
                    JohnGoodwin
                    Depends on the OS, it could be added as a JVM option in the registry or to custom params script but I wasn't really aiming this config at your post.
                    But by the sounds of it you don't have enough memory on the machine so setting the JVM max to a high value will not be wise.

                    Cheers

                    John
                    http://john-goodwin.blogspot.com/
                    • 7. Re: JVM is -Xms 1024m -Xmx5120m
                      663057
                      Thanks for the insight as i always learn Hyperion from your help.

                      Kindly correct me if i misunderstood-

                      1) I am not going for change of JVM.
                      2) I am not going to set compress parameter as you feel.
                      3) I am Going back and check what was form is causing this Huge memory and then redesign if possible.


                      Any more suggestion?

                      Regards
                      Kumar
                      • 8. Re: JVM is -Xms 1024m -Xmx5120m
                        JohnGoodwin
                        It is up to you if you want to change the JVM settings just don't set it higher than the amount of memory that is available, it is worth investigating at the application side to find the reason why it is requiring additional memory.

                        Cheers

                        John
                        http://john-goodwin.blogspot.com/
                        • 9. Re: JVM is -Xms 1024m -Xmx5120m
                          663057
                          Thanks John

                          Regards
                          Kumar