This discussion is archived
0 Replies Latest reply: May 24, 2012 12:09 PM by Julie Treger-Oracle RSS

Database error thrown when using ODBC 11.01.00.07 with 11.2.0.2

Julie Treger-Oracle Newbie
Currently Being Moderated
A database error is thrown when running Oracle Database 11.2.0.2 with ODBC driver 11g - 11.01.00.07. The error occurs on a Select statement.

The error is:

(37000, 1460) [Oracle][ODBC][Ora]ORA-01460: unimplemented or unreasonable conversion requested

On May 1st I had posted the following:

"Rrunning ODBC driver version is 9.02.00.00 after upgrading to 11g" asking if this driver was compatible with 11g. The response I received was:

"Per Oracle Client/Server interoperability the Oracle Client has to be at a minimum of 9.2.0.4 or higher to connect to an 11.2 RDBMS. Understand however that 9.2 has not been desupported for error correction for a while so if you run into new issues after upgrading to the 9.2.0.8 terminal patches the only other suggestion is to upgrade to 11g preferably 11.2.0.3".

Since my customer is running 11.01.00.07 and not the preferable 11.2.0.3, is it possible that the error mentioned above could occur because the ODBC driver is not at version 11.2.0.3?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points