1 2 Previous Next 16 Replies Latest reply: May 28, 2012 8:18 AM by 848975 RSS

    How to change OIM port?

    848975
      Hello,
      I want to change the port of already installed OIM. It is on 14000 and I want to access it from 10100 port.
      I have tried following step but could not get any help :
      1). Login to http://Admin_Server/ em.
      2). Navigate to Identity and Access, oim.
      3). Right-click oim, and navigate to System MBean Browser.
      4). Under Application Defined MBeans, navigate to oracle.iam, Application:oim, XMLConfig, Config, XMLConfig.DiscoveryConfig, and then Discovery.
      5). Enter new value for the OimFrontEndURL attribute, and click Apply to save the changes.

      But it is still opening at port 14000 and not on 10100.
      Kindly help.

      Regards
      Rohit
        • 1. Re: How to change OIM port?
          Kuldeep
          Hi,
          It seems you have followed the each steps of
          http://docs.oracle.com/cd/E21764_01/doc.1111/e14308/handlinglcm.htm#CIABGFEH

          i have done it before for different port, Please check the new port is open or not.

          Have you tried it after restarting the manage server along with admin server?

          Thanks,
          Kuldeep
          • 2. Re: How to change OIM port?
            848975
            I have tried to change the port to 10100 as well as 11000. I restarted the system and Admin and Managed servers but still no result.
            Weblogic admin console shows the same port for oim_server i.e. 14000 and browser is giving error page.
            • 3. Re: How to change OIM port?
              Kuldeep
              Rohit,

              Can you follow the steps.

              Start all OIM manage server if it is not started already.


              1.     Login to em console.
              2.     Navigate to weblogic Domain-> “your domain Name” - > right click ->System Mbean Browser - >
              Provide search Criteria Mbean Name = “Discovery”.
              4.     You result count should be equal to as many as your OIM Managed Server are configured.
              5.     Verify Application Defined MBeans: XMLConfig.DiscoveryConfig:Discovery as name of Mbean.
              6.     Modify “Discovery Config OIM front end URL” and point it to the Proxy Server URL e.g. Discovery Config OIM front end URL= http://url:port

              Access the url, if not able to access restart all the servers and try.
              Let us see the result.

              Kuldeep
              • 4. Re: How to change OIM port?
                848975
                In Step 2 - Discovery is not present under weblogic domain. It is present under Identty and Access:OIM.
                Where it should be ideally?
                • 5. Re: How to change OIM port?
                  Kuldeep
                  It is there.

                  +Weblogic Domain -> Expand -> You will get your domain name (oimdomain) -> right click on oimdomain -> click on "System MBean Browser" -> click on find button on right pannal -> search for   "Discovery " ->

                  You shoud get this.
                  any way that is same mbean, but may be the case that mbeans won't be modify via IAM.

                  -kuldeep

                  Edited by: Kuldeep on May 23, 2012 6:44 AM
                  • 6. Re: How to change OIM port?
                    BikashBagaria
                    Two steps:
                    1. Login to Weblogic Admin Console and change the port of the server where oim is deployed (default is oim_server1)
                    2. Login into EM and change the DiscoveryServer mbean and the oimFrontEndUrl mbean and etc.

                    -Bikash
                    • 7. Re: How to change OIM port?
                      848975
                      After changing the listening OIM port in weblogic admin console and and doing the changes in em, I restarted the system and servers but while starting OIMManaged Server it gave me error. It got started , up and running but with error: " Network Adapter could not establish the connection".
                      Now may be because of this error - the browser is showing 404 error and in em I am not able to get Discovery Mbean which was visible earlier.
                      • 8. Re: How to change OIM port?
                        Kuldeep
                        Rohit,

                        You can revert your changes to make OIM works. After that, if OIM will be in working condition,You can give one more try.
                        But best way raise an SR.

                        Extract oim-config.xml from mds.
                        Take a backup of this file.
                        Make the changes in oimFrontEndUrl section.
                        Import it back in mds.
                        restart the server


                        But one more thing, we have followed the exact same step earlier mentioned in my post. It has worked, why not for you I don't understand. Which version of OIM you are using?

                        -kuldeep
                        • 9. Re: How to change OIM port?
                          848975
                          Kuldeep,
                          It was working once I made change in weblogic admin console. OIM was opening at 11000 port. But when I restarted servers, both OIM and SOA managed servers threw above mentioned error.
                          I am using OIM 11g on Linux machine.
                          • 10. Re: How to change OIM port?
                            Kuldeep
                            Rohit,
                            I don't think you need to change the port in admin console, Any way Bikash has better experience, let him reply.
                            -kuldeep
                            • 11. Re: How to change OIM port?
                              848975
                              I am getting this error in OIM Managed server logs:

                              *<oracle.wsm.policymanager.bean.util.PolicySetBuilder>the policy referenced by URI "oracle/wssll_saml_or_username_token_message_protection_service_policy" could not be retrieved as connection to Policy Manager cannot be established at "t3://localhost.localdomain:8001, localhost.loccaldomain:11000" due to invalid configuration or inactive state.*

                              And in SOA managed server logs:
                              Could not create pool connection : Network Adapter could not establish the connection.

                              Before changing the ports there were no such errors.
                              • 12. Re: How to change OIM port?
                                Kuldeep
                                Have you revert back your changes?
                                • 13. Re: How to change OIM port?
                                  848975
                                  I changed the port back to 14000. but still it is giving same error. Pls tell me the steps other than this to revert back the changes.
                                  • 14. Re: How to change OIM port?
                                    Kuldeep
                                    I want to know have you change host file entry?
                                    /etc/hosts/ file entry should like below. Also first line should be *127.0.0.1 localhost.localdomain localhost*
                                    Also check hostname in network file.


                                    It should value like below.
                                    127.0.0.1 localhost.localdomain localhost
                                    ::1 localhost6.localdomain6 localhost6
                                    192.168.X.X host1 host1

                                    If hostname entry is fine, than you can go option below.
                                    Make sure import of oim-config.xml file should be in proper place.

                                    Extract oim-config.xml from mds.
                                    Take a backup of this file.
                                    Make the changes in oimFrontEndUrl section (t3://*localhost*:14000) not localhost.localdomain
                                    Import it back in mds.
                                    restart the server

                                    -kuldeep
                                    1 2 Previous Next