2 Replies Latest reply: Jun 1, 2012 7:50 AM by Todd Little-Oracle RSS

    Tuxedo Performance Analysis - Query - tried txrpt not receiving report

    Deb_1
      Hi All,

      We have currently migrated from Solaris-8 - Tuxedo 8 environment to Solaris 10 - Tuxedo 11gr1 Staging environment.

      All the application binaries were running fine.

      However we conducted a performance testing for 500 users we could see the performance coming down, when compared to our old performance report of

      Solaris 8 - tux8 environment.

      However we doubt it may be some issue with the network or some other server via which the requests are hitting or responses leaving our system.

      Can you suggest any utility or its usage by which we can check that our current Tuxedo version is working fine than the older one?

      Like how much time tuxedo is taking now to process,the throughputs.

      can you please suggest some way to monitor or generate some sort of report to compare tuxedo 8 performance and Tuxedo 11g R1 performance for same application.



      tried the txrpt

      I5_RQMG_0002_00
      SRVGRP=AQUREQGRP
      SRVID=2000
      CLOPT="-r -s PSY_MG_0002_00:I5_RQMG_0002_00 -o logs/slog/I5_RQMG_0002_00.out -e logs/slog/I5_RQMG_0002_00.err"
      MIN=1 MAX=1
      RQADDR="I5_RQMG_0012_00Q2"
      REPLYQ=Y

      for this above server :

      -rwxrwxrwx 1 tuxedo tuxedo 71022518 May 29 14:56 I5_RQMG_0002_00.err

      I get the above file generated.

      Executed the command:
      tuxconsolas1:/apps/tuxapps/intserv/logs/slog>txrpt -nPSY_MG_0002_00 -d05/29 -s02:00 -e14:00 I5_RQMG_0002_00.err > txrpt.out

      I am just receiving :
      tuxconsolas1:/apps/tuxapps/intserv/logs/slog>less txrpt.out
      START AFTER: Tue May 29 02:00:00 2012
      END BEFORE: Tue May 29 14:00:00 2012

      in the report and the process hangs for me.

      Am i doing any error?

      Edited by: 835542 on May 29, 2012 10:27 AM