7 Replies Latest reply: Jun 25, 2012 10:03 PM by Michael Armstrong-Smith RSS

    Discoverer 11.1.1.4 download

    940407
      Where can a customer download Discoverer 11.1.1.4 ?
        • 1. Re: Discoverer 11.1.1.4 download
          Michael Armstrong-Smith
          Hello
          Why are you looking for 11.1.1.4. I recommend you apply patch 11.1.1.6. From my notes I believe 11.1.1.4 is buggy.

          Best wishes
          Michael
          • 2. Re: Discoverer 11.1.1.4 download
            jlmorris
            Hi Michael,

            Forgive me for butting in, but is 11.1.1.6 available? We are on 11.1.1.4 and so far have not noticed any issues other than we had to patch our client software (both admin and desktop) due to some issue that escapes me right now.

            I will have to look for 11.1.1.6 if it is available for Discoverer.

            If I recall correctly, the last I remember is that Oracle was actually recommending holding at 11.1.1.3, but we are already on 11.1.1.4.

            Regaads,
            Jerry
            • 3. Re: Discoverer 11.1.1.4 download
              Michael Armstrong-Smith
              Hi Jerry
              IMPORTANT NEW MESSAGE: I want to update this thread because on my system I was unable to get Discoverer 11.1.1.6 Plus or Viewer to connect to my database. Oracle were able to reproduce this internally so for now I would advise you not to upgrade to 11.1.1.16.

              Original Text:
              --------------
              Yes 11.1.1.6 is available. It is available as a Patch from MetaLink. It is not available as a stand-alone install.

              Best wishes
              Michael

              Edited by: Michael Armstrong-Smith on Jun 7, 2012 1:47 PM
              • 4. Re: Discoverer 11.1.1.4 download
                jlmorris
                Thank you very much for the update Michael!

                I will hold off on pursuing this patch for now.

                Regards,
                Jerry
                • 5. Re: Discoverer 11.1.1.4 download
                  Michael Armstrong-Smith
                  Hi Jerry
                  I got information back from Oracle that the problem with 11.1.1.6, which uses WebLogic 10.3.6, is the Java version. As part of the install I was advised to download and install the most recent Java Development Kit which at the time was 7.1.4. It turns out that Java 1.7 does not work with WebLogic and so the error was being thrown.

                  Leaving my installation as is, without removing or reinstalling anyting, I was advised to go and get the Java 1.6 JDK and install that. Once installed I had to make a couple of adjustments to a config file. With this done Discoverer ran perfectly.

                  So, 11.1.1.6 is ok so long as you use WebLogic 10.3.6 and Java JDK 1.6. I used version 32 but 31 works too.

                  Hope this helps
                  Michael
                  • 6. Re: Discoverer 11.1.1.4 download
                    jlmorris
                    Thank you for that follow-up Michael. I will work with the DBAs to get 11.1.1.6 and get it applied in our test environment.

                    Regards,
                    Jerry
                    • 7. Re: Discoverer 11.1.1.4 download
                      Michael Armstrong-Smith
                      Jerry
                      I also heard that Oracle have a patch for 11.1.1.6 that will allow Java 1.7 to work.

                      Discoverer 11g is now compatible with JDK 1.7 (server-side) and / or JRE 1.7 plugin (client-side) with Patch 13877486

                      Oracle has updated or published the following technical notes on MyOracle Support Portal:

                      Discoverer 11g With Java 1.7 (JDK or JRE) Fails With Exceptions (DocID 1469683.1) How To Find Oracle BI Discoverer 10g and 11g Certification Information(Doc ID 233047.1)
                      ALERT: Required and Recommended Patch Levels For All Discoverer Versions (Doc ID 237607.1)

                      The patch is about 40 Mb in size and appears to be a generic patch for all platforms. You will need to apply it on the server using OPatch.

                      Hope this helps
                      Michael