This discussion is archived
3 Replies Latest reply: Jun 6, 2012 4:44 AM by 488979 RSS

Owb 64-bit import tables from MS Access or Excel fails

488979 Newbie
Currently Being Moderated
Hello Everybody,

Problem: Import tables from MS Access does not work on 64-bit machine, 32-bit is no problem. Any help would be very much appreciated!

I’m trying to extract some data from a couple of MS Access databases using ODI CodeTemplates. Therefore I made a new platform and all the translations necessary from datasource specific datatypes to generic datatypes.
This all works well on a 32-bit machine. When I import a couple of tables, I can see all the tables available of the MS Access database. When importing it takes about 50 seconds before getting a recap-screen with the tables being imported. All tables are imported correctly with all the correct datatypes.

Now I must do the same for a 64-bit machine + 64-bit OWB installation.

I downloaded the drivers from http://www.microsoft.com/en-us/download/details.aspx?id=13255 . It looks like the drivers are correctly installed on windows, I can see them in my “Datasources (ODBC)” screen in Windows. The adjustment in the location of OWB seems correct, when I test my connection I get the response “SUCCESSFUL”. When I try to make the import, I can see all the available tables. After selecting a couple of tables and click import, the screen immediately disappears. The import seems to be failed, but I get no errors on my screen. When I create a table manually with a couple of columns and select “VIEW DATA”, then the correct data is shown.

Does anyone have an idea what to do or what I can test or have a workaround? It’s a bit frustrating because it works fine on a 32-bit machine, using the same driver (but then of course the 32-bit version). Any help would be very much appreciated!

Details:
-OWB 11.2.0.3
-db 11.2.0.3
- Windows 2008 R2 standard
- Driver class: sun.jdbc.odbc.JdbcOdbcDriver
- ODBC Driver: jdbc:odbc:Driver={Microsoft Access Driver (*.mdb, *.accdb)};DBQ=<<path>>;')
  • 1. Re: Owb 64-bit import tables from MS Access or Excel fails
    488979 Newbie
    Currently Being Moderated
    In addition to the above:

    For test purposes I tried to create the table manually. With "data" I can see the data in the table of the MS Access database.

    I created the mapping exactly the same as I did on the 32-bit server, which worked fine on the 32-bit. But deploying the CodeTemplates and the mapping for the "DEFAULT_AGENT" seems to fail. They all are successfully validated, but I still receive an error:

    Error Message:
    Name: ICT_ORACLE_AW_INCR_UPD
    Action: Create
    Status: Error
    Log:oracle.oc4j.rmi.OracleRemoteException

    The connectors + target objects are succesfully deployed.

    Help will be very much appreciated!
  • 2. Re: Owb 64-bit import tables from MS Access or Excel fails
    David Allan Guru
    Currently Being Moderated
    It sounds like there is a problem with using the driver on 64 bit... to narrow down the problem you can try running the following tcl after you have changed to your driver, URL and credentials. This will mimic some of the calls being made and made help you get up and running. If this works, then it may be the retrieval of keys through the driver, but this is a basic test first ....

    https://blogs.oracle.com/warehousebuilder/resource/OWB11gR2/imp_db_test.tcl

    Cheers
    David
  • 3. Re: Owb 64-bit import tables from MS Access or Excel fails
    488979 Newbie
    Currently Being Moderated
    Hello David,
    Thanks for your reaction!

    I will post the outcome as soon as I'm able to run this script

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points