3 Replies Latest reply on Mar 13, 2013 9:23 PM by 996743

    'OraOLEDB.Oracle.1' provider is not registered on the local machine

      Hello all,

      I'm attempting to set up the 64-bit oledb driver (Oraoledb.Oracle) on a Windows 7 64-bit machine so that I can use in in my .NET application. I have downloaded the 64-bit Oracle Data Access Components from oracle.com and registered the OraOLEDB11.dll on my machine with regsvr32. However, when I attempt to use the provider in my .NET application, I still receive the "'OraOLEDB.Oracle' provider is not registered on the local machine" message. Any ideas or suggestions would be great. I'm really stumped on this......


        • 1. Re: 'OraOLEDB.Oracle.1' provider is not registered on the local machine
          After some more research, I found the issue to my problem. In the readme.htm file that's included in the unzipped 64-bit providers folder, it explains that after you install the files through install.bat, you need to place the location you installed the files in the PATH variable for windows. For example, if you use the install.bat file to install the files at C:\Oracle, you need to place the paths "C:Oracle" and C:\Oracle\bin" in the PATH variable. You can find this variable by right-clicking on My computer and selecting Properties (for Windows Vista/7 users, it's right clicking on Computer then properties then advanced system settings). Click on the Advanced tab and click the Environment Variables button. In the Systems variables list, you'll find the PATH variable. I hope this helps someone else.... I worked on getting the oledb provider to work for days...


          • 2. Re: 'OraOLEDB.Oracle.1' provider is not registered on the local machine
            Thanks, Jonathan, it helped. I was deploying SSIS package (which uses Oracle OLE DB provider) to a 64-bit environment and faced the same issue.
            Wow, who new that old DOS-age path stuff still matters!
            • 3. Re: 'OraOLEDB.Oracle.1' provider is not registered on the local machine
              HI Guys!

              I have installed the 64 bit ORAOLEDB and I get the above message:

              1. When I run it on my local machine it accesses the Oracle on another server successfully, but
              2. When i deploy the c# app to another machine I get this error above.
              2a. The other machines DSN test connection works fine.
              3. I have set the environment PATH
              4. I Have regsvr32'd the dll
              5. I have re checked the permissions boxes

              on the deployed machine, with no luck.

              Im at a loss????