This discussion is archived
1 Reply Latest reply: Jun 4, 2012 11:21 PM by Stephen French RSS

OPM 10.4 Test Script Memory Error

855471 Newbie
Currently Being Moderated
Hi,

I have a large rulebase that I am working with that was developed in OPA 10.3. I've upgraded the rulebase to 10.4 for a client to take advantage of the new coverage report. For the most part the upgrade is pretty straight forward but I am getting an error when I attempt to open the newly updated test scripts. I've tried creating the scripts from scratch and I get the same error. Additionally, I get the same error when i try to run the 10.4 coverage report. This appears to be an issue with virtual memory not physical. Error is System.OutOfMemoryException.Exception Any ideas?

Thanks
  • 1. Re: OPM 10.4 Test Script Memory Error
    Stephen French Journeyer
    Currently Being Moderated
    Memory usage with large test scripts was a known problem (and we have made significant improvements in the forthcoming 10.4.1 release to address this), however it's strange that you encounter a problem even when creating the test scripts from scratch.

    Are you removing the existing test scripts from the project first? One of the problems in 10.4.0 (and earlier releases) is that it keeps part of the test script open when the project is open, even when you don't have the test script open for editing.

    Also, a little more detail on the specific error would be helpful. eg. When does the error occur? Are you able to run test scripts in isolation successfully?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points