8 Replies Latest reply: Jun 7, 2012 8:15 AM by 936749 RSS

    X and display

    936749
      Hi,
      I just now tried to access dbca through putty(X forwarding enabled) with xming and recived the following error:
      [oracle@EXA01 bin]$ ./dbca
      DISPLAY not set.
      Set DISPLAY environment variable, then re-run.
      I tried xterm as Oracle but it's not availible to Oracle.

      And yeah we use Oracle Linux.

      If anyone have documentation on this please link.

      Edited by: 933746 on Jun 5, 2012 10:44 AM

      Edited by: 933746 on Jun 5, 2012 10:45 AM
        • 1. Re: X and display
          SAmi389588
          Dear

          please write the cmd of export DISPLAY that you run it

          Ex:
          $ export DISPLAY=10.31.19.93:0.0
          $ dbca

          Regards
          A.M
          • 2. Re: X and display
            user10489439
            When using ssh, you don't need a DISPLAY variable.

            Do you connect to your EXA01 server as root and changes to the oracle account with su? The easiest way is a direct connection to the oracle account on the EXA01 server with ssh. Should this not possible you have to use "ssh -X" for every further connection.

            Best regards
            Antje
            • 3. Re: X and display
              936749
              Hi,
              Thanks for the answers...
              I'm connecting from my client computer a Windows 7 with putty (X forwarding) and have installed Xming. This works for most environments but not against our new Exadata's. I connect as Oracle and i do not change user.
              As far as I can understand in the documentation there should be no need to use EXPORT DISPLAY=
              Anyone have any idea on how to resolve this issue?
              • 4. Re: X and display
                936749
                I've also tried with exporting display but still nothing works.
                [oracle@exa1 bin]$ export DISPLAY=localhost:10.0
                [oracle@exa1 bin]$ ./dbca
                [oracle@exa1 bin]$ export DISPLAY=localhost:0.0
                [oracle@exa1 bin]$ ./dbca

                And if I try from a Linux install (Ubuntu) I get this message when logging on:
                X11 forwarding request failed on channel 0
                And this when I try to start DBUA:
                [oracle@exa1 bin]$ ./dbua
                DISPLAY not set.
                Set DISPLAY environment variable, then re-run.

                Edited by: 933746 on Jun 5, 2012 2:19 PM
                • 5. Re: X and display
                  tychos
                  Hi,
                  Did you changed the X11Forwarding setting on the Exadata compute nodes side in sshd_config?
                  File
                  /etc/ssh/sshd_config
                  Section
                  # Accept locale-related environment variables
                  Change to yes
                  X11Forwarding yes
                  Please post your result
                  Regards,
                  Tycho
                  • 6. Re: X and display
                    936749
                    tychos wrote:
                    Hi,
                    Did you changed the X11Forwarding setting on the Exadata compute nodes side in sshd_config?
                    File
                    /etc/ssh/sshd_config
                    Section
                    # Accept locale-related environment variables
                    Change to yes
                    X11Forwarding yes
                    Please post your result
                    Regards,
                    Tycho
                    Hi, I need root access to modify this file. I'll update as soon as I've managed to logon as root (don't have the new password atm)
                    Regards
                    Mr 933746
                    • 7. Re: X and display
                      robinsc
                      alternatively I belive installation of a vnc server is supported on the compute nodes and then you can use vnc viewer for any x display work...
                      • 8. Re: X and display
                        936749
                        Hi, Thanks this solved my problem.