0 Replies Latest reply: Jun 12, 2012 1:14 AM by 663779 RSS

    read JAX-WS : wrap methods: Expose as JAX-RPC

      We have been developing applications using IBM Webspehere Application Developer 5.1.2 (WSAD 5.1.2) which only supports Java 1.4 — hence, most of our existing apps are running on java 1.4 (IBM Webspehere 5.x).
      We have been asked to call a JAX-WS web service within an existing application, but we are unable to do that since IBM WSAD 5.1.2+Java 1.4 only support JAX-RPC web services.

      Is there a way to call a JAX-WS service within a java 1.4 based web application?

      As a workaround, we tried to create a broker service using netbeans to run on Oracle weblogic 12c, to wrap all the methods of the JAX-WS web service and expose it again as a JAX-RPC web service so that our old application
      would access it. But it was not practical since we have to make a decision while selecting the java version of the application. If we chose java 1.4, it also can not access the JAX-WS service and generate all the require classes.
      If we chose java 1.5 or 1.6, it can not expose it's web service as a JAX-RPC service.

      Please do try to give an advice regarding this matter.

      Thanks in advance!!!