3 Replies Latest reply on Jun 22, 2012 5:12 PM by 322268

    Webstart and WorldWind


      I have an eclipse rcp application that was created via a headless build and is launched via webstart. I've been working to add a WorldWind map as a view. When I run in the Eclipse IDE or export the product as an EXE, the application runs correctly and the map is displayed and contains data. When I export the deployable feature and provide the codebase argument for webstart, the application starts without error but the map is not visible. There are no errors in the logs or the java console. Any advice or suggestions would be greatly appreciated.
        • 1. Re: Webstart and WorldWind
          You did not say how you access the map resources.
          Set the java console with proper tracing level, you would see more details. For debugging tips see webstart trouble-shooting guide at:
          • 2. Re: Webstart and WorldWind
            Map is a view in a folder layout within the eclipse application. When I run via the Eclipse IDE or an exported exe, the Map tab appears and I can click on it to display the map. When I run via webstart the tab is not there.

            I changed the trace level to 5 (all) in the java console. I can see where all the features and plugins are being loaded including the map and worldwindx.

            CacheEntry[file:/c:/temp/client/features/com.xxx.client_1.0.0.jnlp]: updateAvailable=false,lastModified=Wed Jun 13 09:46:00 MDT 2012,length=3119
            CacheEntry[file:/c:/temp/client/features/org.eclipse.rcp_3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A.jnlp]: updateAvailable=false,lastModified=Wed Jun 13 09:48:21 MDT 2012,length=7258
            CacheEntry[file:/c:/temp/client/features/com.xxx.map.feature_1.0.0.jnlp]: updateAvailable=false,lastModified=Wed Jun 13 09:45:51 MDT 2012,length=497
            CacheEntry[file:/c:/temp/client/features/gov.nasa.worldwindx.feature_1.2.0.jnlp]: updateAvailable=false,lastModified=Wed Jun 13 09:45:50 MDT 2012,length=478

            CacheEntry[file:/c:/temp/client/plugins/gov.nasa.worldwind_1.2.0.jar]: updateAvailable=false,lastModified=Wed Jun 13 09:44:28 MDT 2012,length=5094142
            CacheEntry[file:/c:/temp/client/plugins/com.xxx.map_1.0.0.jar]: updateAvailable=false,lastModified=Wed Jun 13 09:44:33 MDT 2012,length=288977
            CacheEntry[file:/c:/temp/client/plugins/gov.nasa.worldwindx_1.2.0.jar]: updateAvailable=false,lastModified=Wed Jun 13 09:44:18 MDT 2012,length=3331932

            I looked at the link you provided. Doesn't appear to apply since this is an Eclipse RCP Application and not an applet. Other views in the folder appear as do several other view components.

            Edited by: tjahelka on Jun 13, 2012 10:24 AM
            • 3. Re: Webstart and WorldWind
              Problem resolved. Root cause was the dll's from gluegenrt and jogl (both of which are required by Worldwind) were not being included in the binary build.