5 Replies Latest reply: Jun 15, 2012 7:32 AM by 899632 RSS

    AIA Installation in Cluster.

    765031
      Hi,

      I am trying to install AIA on SOA Suite Cluster.
      While entering the information in SOA Server Details screen, for Cluster Install, it ask for Cluster Proxy Host and Proxy Port.

      The detail for the same as per Installation guide is given as below.

      Cluster Proxy Hostname - The field is enabled only when you select the Cluster Installation option. This value is the loadbalancer host name which you have configured to loadbalance incoming requests to webservers that ultimately reach the SOA managed servers.

      Proxy Port - This field is enabled only when you select the Cluster Installation option. This value is the port number of the proxy server.

      1. Is it necessary to have LoadBalancer into place while doing AIA installation on SOA Cluster? If no, then what should be entered for Cluster Proxy Host and Proxy Port.

      2. I gave Admin Host and Port for Cluster Proxy Host and Proxy Port, it gives an error saying Unable to reach soa-infra through proxy.

      Any helps will be appreciated.

      Regards,
      VM
        • 1. Re: AIA Installation in Cluster.
          765031
          Hi All,

          Could you please provide your inputs on this. Any help will be highly appreciated.

          / VM
          • 2. Re: AIA Installation in Cluster.
            bbukacek
            If you're deploying an HA AIA solution, I would highly suggest having a LB out in front of the cluster or some kind of reverse proxy. Once that is in place, the proxy url will be the LB url and the port for the soa-infra component. This is different than the admin server port. If you followed the EDG, the admin port is 7001 and the soa-infra port is 8001.
            • 3. Re: AIA Installation in Cluster.
              user356390 - oracle
              You can check UPK and Demo at http://www.oracle.com/technetwork/middleware/foundation-pack/overview/soafpclusterupk-1499792.html for Cluster Installation.
              Hope it helps!
              • 4. Re: AIA Installation in Cluster.
                899632
                Hello,

                While installing AIA on SOA cluster, I am getting the following error after the installer progress at 60%.
                Error:
                -------
                [deployComposite] setting user/password..., user=weblogic
                [deployComposite] Processing sar=/u01/app/oracle/mw_soaqat001/Oracle_AIA1/Infrastructure/ErrorHandling/src/AIAErrorTaskAdministrationApp/AIAErrorTaskAdministrationProcess/deploy/sca_AIAErrorTaskAdministrationProcess_rev1.0.jar
                [deployComposite] Adding sar file - /u01/app/oracle/mw_soaqat001/Oracle_AIA1/Infrastructure/ErrorHandling/src/AIAErrorTaskAdministrationApp/AIAErrorTaskAdministrationProcess/deploy/sca_AIAErrorTaskAdministrationProcess_rev1.0.jar
                [deployComposite] INFO: Creating HTTP connection to host:sfrfidcoews003p, port:7150
                [deployComposite] INFO: Received HTTP response from the server, response code=400
                [deployComposite] SEVERE: Problem in sending HTTP request to the server. Please make sure the server is up and/or check standard HTTP response code for 400
                [deployComposite] ---->response code=400, error:null


                I have the following entry in the mod_wl_ohs.conf

                NameVirtualHost *:7150
                <VirtualHost *:7150>
                ServerName http://elb1-soa-vnic-1:7101 (Virtual host for Admin Server and the port of the Admin Server)
                ServerAdmin varm@abc.com
                RewriteEngine On
                RewriteOptions inherit
                </VirtualHost>

                NameVirtualHost *:7150
                <VirtualHost *:7150>
                ServerName sfrfidcoews003p.abc.com:7150 (hostname for OHS, port for OHS)
                ServerAdmin varm@abc.com
                RewriteEngine On
                RewriteOptions inherit
                # Admin Server and EM
                <Location /console>
                SetHandler weblogic-handler
                WebLogicHost elb1-soa-vnic-1
                WeblogicPort 7101
                </Location>
                <Location /consolehelp>
                SetHandler weblogic-handler
                WebLogicHost elb1-soa-vnic-1
                WeblogicPort 7101
                </Location>
                <Location /em>
                SetHandler weblogic-handler
                WebLogicHost elb1-soa-vnic-1
                WeblogicPort 7101
                </Location>
                </VirtualHost>
                • 5. Re: AIA Installation in Cluster.
                  899632
                  Any pointers on this could be great help.. !!