This discussion is archived
7 Replies Latest reply: Mar 15, 2013 10:15 AM by 997210 RSS


644504 Newbie
Currently Being Moderated
I get this every time I start sqldeveloper. It operates normal when I click the OK button in the pop-up window but it is annoying would like for it to stop. Anyone have any suggestions?

     at oracle.jdevimpl.vcs.svn.SVNProfile.canActivate(
     at oracle.jdevimpl.vcs.generic.GenericClient.fireCanActivate(
     at oracle.jdevimpl.vcs.generic.GenericClient.canActivate(
     at oracle.jdevimpl.vcs.VCSManagerImpl$6.addinsLoaded(
     at oracle.ide.IdeCore.fireIdeEvent(
     at oracle.ide.IdeCore.access$100(
     at oracle.ide.IdeCore$
     at java.awt.event.InvocationEvent.dispatch(
     at java.awt.EventQueue.dispatchEvent(
     at java.awt.EventDispatchThread.pumpOneEventForFilters(
     at java.awt.EventDispatchThread.pumpEventsForFilter(
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(
     at java.awt.EventDispatchThread.pumpEvents(
     at java.awt.EventDispatchThread.pumpEvents(
  • 1. Re: java.lang.NullPointerException
    -K- Guru
    Currently Being Moderated
    That's the Subversion plugin - you can disable it in Preferences - Extensions - Versioning Support.

    Hope that helps,
  • 2. Re: java.lang.NullPointerException
    667543 Newbie
    Currently Being Moderated
    I have the same error, and after of disable the versioning extension everything works fine.

  • 3. Re: java.lang.NullPointerException
    841040 Newbie
    Currently Being Moderated
    Thanks guys, this annoying exeption doesn't disturb me anymore :-)
  • 4. Re: java.lang.NullPointerException
    48346 Newbie
    Currently Being Moderated
    I get this error as well. But I want to have Subversion working from within SQL Developer. Any ides appreciated?
  • 5. Re: java.lang.NullPointerException
    user5431290 Newbie
    Currently Being Moderated
    I just went through the same thing...and I too needed to use subversion...

    I downloaded the jdk from oracle and used the 'no-jdk' 3.1 version of sql developer ( i also had a 2.x version of sql developer that worked fine with subversion ) first no joy

    got the oracle.jdevimpl.vcs.svn.SVNProfile.canActivate( error...every time

    When I compared the preferences.xml file from

    C:\Documents and Settings\<me>\Application Data\SQL Developer, I could see several directories reflecting the sql developer installations I had

    In my 2.x installation ...

    C:\Documents and Settings\<me>\Application Data\SQL Developer\system2.

    I found the folder o.jdeveloper.subversion.

    In there...I found preferences.xml...

    In my
    C:\Documents and Settings\<me>\Application Data\SQL Developer\system3.1.07.42 installation which at first did not work...

    I found the
    o.jdeveloper.subversion. folder...which also contained a preferences.xml file...however it was radically shorter and different than the 2.x version...

    Copying the 2.x version to the 3.1 installation folder ( o.jdeveloper.subversion. )...and restarting sql developer did the subversion plug in now appears...

    I have an SR opened with oracle to find out why the file got mangled in the first place...

  • 6. Re: java.lang.NullPointerException
    948465 Newbie
    Currently Being Moderated
    Same problem, slightly different solution:

    I had an empty preferences.xml file in both the 2.0 and 3.1 sql developer, so I tried to simply delete the preferences.xml in the o.jdeveloper.subversion. directory and bingo - no error message any more.

    Hope this helps someone
    Best Regards
  • 7. Re: java.lang.NullPointerException
    997210 Newbie
    Currently Being Moderated
    thanks a lot


  • Correct Answers - 10 points
  • Helpful Answers - 5 points