2 Replies Latest reply: Jun 25, 2012 12:32 PM by 914112 RSS

    Problems with Deploy java.lang.NoClassDefFoundError

      I Have an aplication in Jdeveloper, i make the ear for the aplication and i tried to deploy it on the embebed weblogic of my jdeveloper and in a weblogic 10.3.6 with the patch for adf (the server its fine because i have other aplications running on it).

      The deploy goes well, i can access to some pages and work with the application BUT when a access to a page with input Date control the page return this error.

      java.lang.NoClassDefFoundError: oracle/adf/view/rich/component/rich/input/RichInputDate
           at java.lang.Class.getDeclaredMethods0(Native Method)
           at java.lang.Class.privateGetDeclaredMethods(Class.java:2427)
           at java.lang.Class.getDeclaredMethods(Class.java:1791)
           at oracle.adfinternal.controller.beans.AnnotationUtils.findAnnotatedMethods(AnnotationUtils.java:194)
           at oracle.adfinternal.controller.beans.AnnotationUtils.runPostConstructIfSpecified(AnnotationUtils.java:63)

      i tried to put the adf-richclient-api-11.jar in the viewController project and deploy, but the problem persist

      Edited by: UserMan on 25-jun-2012 8:02