This discussion is archived
8 Replies Latest reply: Jun 27, 2012 8:49 AM by 839952 RSS

10g Write back works for some users, not others

839952 Newbie
Currently Being Moderated
Dear Gurus,

I have a strange problem with the Write Back in my system. We use Write-back pretty extensively and have maybe 10-20 separate reports, updating a number of tables.

We have been using this system for almost a year with no problems - Myself (logging in as Administrator) and a member of the Business team, logging in as herself (a member of the Presentation Server Administrator Group).

We now require two more Business power-users to use our Write-back reports. I have added them to the Presentation Server Administrator group. However, when they try to enter values into ANY of the write-back reports, they get the following error;

An error occurred while writing to the server. Please check to make sure you have entered appropriate values. If the problem persists...

*State: HY000. Code 10058 [NQODBC]... A general error has occurred. [nQSERROR 27024] The EXECUTE PHYSICAL statement must specify a physical SQL statement to execute (HY000)*

SQL issued: EXECUTE PHYSICAL CONNECTION POOL "GL Oracle Data Warehouse Connection Pool"

I do not understand why the write back is working without error for my own user, the Admin user and a member of the business team who is in the Presentation Server Administrator group, but not for two new additions to that group.

I have checked that the Presentation Server Admin group is granted on the "Enable/Manage Write Back" privilege and on the Execute SQL privilege.

Any ideas what else I could check?

Thanks,

A.
  • 1. Re: 10g Write back works for some users, not others
    AmithY Expert
    Currently Being Moderated
    Do you know if those two users you have added to presentatoin server administrator groups are actually part of other groups that is denied access to the connection pool used for the write back? Remember, the deniel permission takes precedence any day over granted.

    Thanks,
    -Amith.
  • 2. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    Hey Amith,

    Thanks for your quick reply! Unfortunately, this doesn't seem to be the case. The system is pretty much wide open, apart from the Write pack privilege, which only the Presentation Server Administrator group has access to.

    I'm having another of my Presentation Server Administrators who has been in the group forever try to use the write back.

    There's no specific connection pool or database level permissions for write back, is there? And there's no specific permissions which need to be set on the xml template files?

    Thanks,

    A.
  • 3. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    Hey Amith,

    Thanks for your quick reply! Unfortunately, this doesn't seem to be the case. The system is pretty much wide open, apart from the Write pack privilege, which only the Presentation Server Administrator group has access to.

    I'm having another of my Presentation Server Administrators who has been in the group forever try to use the write back.

    There's no specific connection pool or database level permissions for write back, is there? And there's no specific permissions which need to be set on the xml template files?

    Thanks,

    A.
  • 4. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    Edit: Wow, triple post! Sorry about that.

    Edited by: Ally on Jun 25, 2012 12:17 PM
  • 5. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    I also tried to open the Writeback up to ALL users - full control. I then asked a number of users to try the write back, and they all got the same error. I, and the other Business power user, can still use the write back in the reports without any issues.

    Am going mad.
  • 6. Re: 10g Write back works for some users, not others
    772777 Journeyer
    Currently Being Moderated
    How about the permissions on these columns in presentation layer in RPD?, do they have write access?
  • 7. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    Hey,

    In the RPD, all my columns for the table I'm writing back to have the property "Everyone: Read". And that's it. Still doesn't explain why I can write back with my user.

    I have tried adding other users to the Presentation Server Administrators group and getting them to write back - but they get the same error, so I'm missing something - I and the other business user it works for must have some setting or privilege which the others don't. I am blowed if I can find what it is though!

    Thanks.
  • 8. Re: 10g Write back works for some users, not others
    839952 Newbie
    Currently Being Moderated
    Solved - It was a grouping/permissions issue. Bumped up the privs of my users - added XMLP_Admin and all that other stuff and it's working.

    So for future reference: If your writeback functions for some users but not for others - check out the Privileges assigned to the users that are working, and compare them to the privs of the users that don't work. The difference is where you will find the answer.

    Thanks for the input.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points