1 Reply Latest reply on Jun 26, 2012 8:14 AM by 945789

    Debugging jnlp application (Java 1.6) problem..

      Im trying to debug a jnlp that we have deployed. I have tried the following options:

      javaws -J-Xdebug -J-agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n http://mywebmachine.internal.com/1.6/link_OIL-ID_Remote.jnlp

      javaws -J-Xdebug -J-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n http://mywebmachine.internal.com/1.6/link_OIL-ID_Remote.jnlp

      In either case, if I try to telnet to this port, it fails:
      C:\>telnet 8787
      Connecting To not open connection to the host, on port 8787: Connect failed

      C:\>telnet localhost 8787
      Connecting To localhost...Could not open connection to the host, on port 8787: Connect failed

      I used the information from these forum posts, but it isn't helping me get any leads...
      http://java.dzone.com/articles/debugging-java-web-start (Help for JWS 1.5)
      http://docs.oracle.com/javase/1.5.0/docs/guide/javaws/developersguide/troubleshooting.03.06.html (Comparison between 1.5 & 1.6)

      Can anyone help me figure out how I can debug Java Web Start application? The machine which runs the JWS is:
      java version "1.6.0_24"
      Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
      Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode, sharing)

      I'll be using IntelliJ IDEA 10.0 to connect & debug this process
        • 1. Re: Debugging jnlp application (Java 1.6) problem..
          A good piece of information supplied by this article:

          is that though JavaWS gives the -J option to supply it's VM with options, there can be another catch:

          <j2se ... />

          By using this tag in your JNLP file, it causes to load another VM and to this -J parameter does not apply. However, this tag accepts it's own "java-vm-args", but it does not support "-Xrunjdwp" argument. Paradox! Workaround is not to use this tag in development mode, where debugging is needed. In live, where you don't have to debug, you can use this tag.

          I tried this as well, but didn't help my case. Im going to clear my JavaWS cache and try again .. I'll let you know if I see any progress...