0 Replies Latest reply on Jul 8, 2012 7:40 PM by 948073

    Time-out checking log bucket location.


      Earlier this month, I successfully ran the OSB Cloud Module for Amazon S3 installer. It created a "new registration for this S3 user" with a new "Registration ID". It also generated an "S3 Logging Bucket" with a name based off of my Amazon nickname which at the time of running the Cloud module installer was "javanetworking".

      $ *./osbws_install.sh*
      Oracle Secure Backup Database Web-Service Install Tool, build 2011-02-04.0001
      AWS credentials are valid.
      Creating new registration for this S3 user.
      Created new log bucket.
      Registration ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
      S3 Logging Bucket: oracle-log-javanetw-1
      Validating log bucket location ...
      Validating license file ...
      Create credential oracle.security.client.connect_string1
      OSB web-services wallet created in directory /u01/app/oracle/product/11.2.0/dbhome_1/dbs/osbws_wallet.
      OSB web-services initialization file /u01/app/oracle/product/11.2.0/dbhome_1/dbs/osbwstestdb1.ora created.
      Downloading OSB Web Services Software Library from file osbws_linux64.zip.
      Downloaded 20744341 bytes in 10 seconds. Transfer rate was 2074434 bytes/second.
      Download complete.
      Extracted file /u01/app/oracle/product/11.2.0/dbhome_1/lib/libosbws12.so

      Since then, I have changed my Amazon nickname (https://www.amazon.com/gp/nickname/index.html"). I was hoping to re-run the Cloud module installer and have it generate a new "S3 Logging Bucket". I removed the two S3 buckets that were created in the initial Cloud module install (the data and log buckets).

      However, when I attempt to re-run the Cloud module installer, it complains that it cannot find the original "S3 Logging Bucket":

      $ *./osbws_install.sh*
      Oracle Secure Backup Database Web-Service Install Tool, build 2011-02-04.0001
      AWS credentials are valid.
      S3 user already registered.
      Registration ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
      S3 Logging Bucket: *oracle-log-javanetw-1*
      Validating log bucket location ...
      Time-out checking log bucket location.
      Please try again later.

      I even tried using the *-newLogBucket* option to osbws_install.jar so it would force the creation of new log bucket; however, it doesn't appear to do anything. It still complains about not finding the original S3 Logging Bucket.

      I thought the best option would be to "un-register" the Amazon S3 user the installer generated. There is no documented option in osbws_install.jar to perform a full "un-install" or "un-register". The Registration ID the installer creates appears to be hard-coded metadata somewhere in Amazon S3.

      +AWS credentials are valid.+
      +S3 user already registered.+
      +Registration ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx+

      I know that the registration information is not stored with your OTN profile because I tried putting in a fake OTN username/password when calling osbws_install.jar. It doesn't use the OTN username/password because it first uses your AWSID/AWSKey to see if there is information that the S3 user is already registered. Once it determines that the S3 account is already registered, it doesn't need to log in to OTN and displays:

      *S3 user already registered.*

      I did try this and it worked for modifying the backup bucket (OSB_WS_BUCKET) but didn't appear to work for the S3 Logging Blucket (_OSB_WS_LOG_BUCKET).

      1.) Manually re-create the missing S3 Logging Bucket (oracle-log-javanetw-1).
      2.) Run the Cloud module installer so it creates the wallet, configFile, and downloads the library.
      3.) Determine list of valid parameters that can be set in the configFile:

      $ *strings $ORACLE_HOME/lib/libosbws12.so | grep '^OSB_' | sort*
      OSB_WS_BUCKET <----------

      $ *strings $ORACLE_HOME/lib/libosbws12.so | grep '^_OSB_' | sort*
      _OSB_WS_LOG_BUCKET <----------

      4.) Modify the configFile to include:

      $ *cat $ORACLE_HOME/dbs/osbwstestdb1.ora*
      OSB_WS_WALLET='location=file:/u01/app/oracle/product/11.2.0/dbhome_1/dbs/osbws_wallet CREDENTIAL_ALIAS=idevjhun_aws'


      1.) Is the *-newLogBucket* option broke or an unimplemented method?
      2.) Is there a way to "un-register" or modify the S3 registration information so that the Cloud module installer will register a new S3 user? (i.e. starting from scratch)
      It would seem to me that a user might want to completely uninstall and un-register at some time in the future.
      3.) Where is the "Registered S3 User" metadata stored?
      4.) Can you specify the S3 Logging Bucket (and data bucket) during the install?

      There is a similar post which the user ran into the same issue when removing the S3 Logging Bucket.

      Best regards,