This discussion is archived
2 Replies Latest reply: Jul 17, 2012 8:04 PM by 946586 RSS

Unable to start Workshop after upgrading JRockit from R5 to R28

946586 Newbie
Currently Being Moderated
I have Workshop 10.3 installed together with the bundled JRockit 1.6.0 R5. Recently, I upgraded the JRockit version to 1.6.0 R28 and have been unable to start Workshop.

Here is the error I get after trying to run workshop.exe:

JVM terminated. Exit code=13
D:/Program Files/Java/jrockit-jdk1.6.0_26-R28.1.4-4.0.1/jre/bin/javaw.exe
-Xms384m
-Xmx768m
-XX:MaxPermSize=256m
-XX:PermSize=192m
-XX:NewRation=3
-Xss256k
-DprodMode=production
-Dweblogic.deployer.debug=all
-Dweblogic.debug.DebugConnection=true
-Dweblogic.debug.DebugMessaging=true
-Dweblogic.debug.DebugDeployment=true
-Dweblogic.home=D:/Oracle/Middleware/wlserver_10.3
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Dnitrox.boot.jar=file:D:/Oracle/Middleware/wlserver_10.3/nitrox-boot.jar
-Dosgi.install.area=D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse
-Dosgi.instance.area.default=E:/BeaApps/MgmtPortal/workspaces/default
-Dosgi.configuration.area=D:/Oracle/Middleware/workshop_10.3/workshop4WP/eclipse/configuration
-Declipse.product=com.bea.workshop.product.workshop
-Dosgi.splashPath=file:D:/Oracle/Middleware/workshop_10.3/workshop4WP/eclipse/plugins/com.bea.workshop.product
-jar D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20080118awtswtbridge.jar
-os win32
-ws win32
-arch x86
-showsplash
-launcher D:\Oracle\Middleware\workshop_10.3\workshop.exe
-name Workshop
--launcher.library D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20080118\eclipse_1023.dll
-startup D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20080118awtswtbridge.jar
-exitdata 143c_70
-vm D:/Program Files/Java/jrockit-jdk1.6.0_26-R28.1.4-4.0.1/jre/bin/javaw.exe
-Xms384m
-Xmx768m
-XX:MaxPermSize=256m
-XX:PermSize=192m
-XX:NewRation=3
-Xss256k
-DprodMode=production
-Dweblogic.home=D:/Oracle/Middleware/wlserver_10.3
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Dnitrox.boot.jar=file:D:/Oracle/Middleware/wlserver_10.3/nitrox-boot.jar
-Dosgi.install.area=D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse
-Dosgi.instance.area.default=E:/BeaApps/MgmtPortal/workspaces/default
-Dosgi.configuration.area=D:/Oracle/Middleware/workshop_10.3/workshop4WP/eclipse/configuration
-Declipse.product=com.bea.workshop.product.workshop
-Dosgi.splashPath=file:D:/Oracle/Middleware/workshop_10.3/workshop4WP/eclipse/plugins/com.bea.workshop.product
-jar D:/Oracle/Middleware/tools/eclipse_pkgs/2.0/eclipse_3.3.2/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20080118awtswtbridge.jar



I've tried changing the vm to java.exe and to the jrockit-jre folder, but both give similar errors.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points