1 Reply Latest reply: Jul 10, 2012 1:10 PM by fchagnon RSS

    Unable to remove SAN LUNs from Solaris 10

    920934
      Hi All,

      I'm trying to remove LUNs from Solaris 10 box. After LUNs are properly removed from veritas volume manager and uninitialized I tried to remove it from the system by cfgadm. However I ended with the following error for every LUN ( same with -o force_update ) :

      # cfgadm -o force_update -c unconfigure c1::50001fe1500cb5a9
      cfgadm: Library error: remove operation failed: /devices/pci@2,600000/SUNW,emlxs@0/fp@0,0/array-controller@w50001fe1500cb5a9,0: No such device or address
      #

      # cfgadm -o force_update -c unconfigure c1::50001fe1500cb5a9
      cfgadm: Library error: remove operation failed: /devices/pci@2,600000/SUNW,emlxs@0/fp@0,0/array-controller@w50001fe1500cb5a9,0: No such device or address
      #

      From dmesg I can see following:

      scsi: [ID 243001 kern.info] /pci@2,600000/SUNW,emlxs@0/fp@0,0 (fcp2):
      ndi_devi_online: failed for array-controller: target=289e00 lun=0 ffffffff
      scsi: [ID 243001 kern.warning] WARNING: /pci@2,600000/SUNW,emlxs@0/fp@0,0 (fcp2):
      Failed to create nodes for pwwn=50001fe1500cb5a9; error=5


      Our HBA Cards:

      # fcinfo hba-port
      HBA Port WWN: 10000000c980ecaf
      OS Device Name: /dev/cfg/c1
      Manufacturer: Emulex
      Model: LPe11000-S
      Firmware Version: 2.82a4 (Z3D2.82A4)
      FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
      Serial Number: 0999VM0-0846000NXK
      Driver Name: emlxs
      Driver Version: 2.60k (2011.03.24.16.45)
      Type: N-port
      State: online
      Supported Speeds: 1Gb 2Gb 4Gb
      Current Speed: 4Gb
      Node WWN: 20000000c980ecaf
      HBA Port WWN: 10000000c981d2f0
      OS Device Name: /dev/cfg/c2
      Manufacturer: Emulex
      Model: LPe11000-S
      Firmware Version: 2.82a4 (Z3D2.82A4)
      FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
      Serial Number: 0999VM0-0846000NQ1
      Driver Name: emlxs
      Driver Version: 2.60k (2011.03.24.16.45)
      Type: N-port
      State: online
      Supported Speeds: 1Gb 2Gb 4Gb
      Current Speed: 4Gb
      Node WWN: 20000000c981d2f0
      #

      We using EVA8000/8001 storage

      Any idea why those LUNs cannot be removed? Btw I already tried also luxadm -e offline <every LUN> to get it to the unusable status but with "cfgadm -c unconfigure -o unusable_SCSI_LUN" I got every time the same error.

      Thanks for help.