0 Replies Latest reply on Jul 16, 2012 11:31 AM by 949277

    404 Error (not found) for webfragment when running from OEPE (split source)

      For a large project, we are developing several JSF modules as JARs which then become packaged inside a single WARs WEB-INF/lib, which in turn will be the only substantial part of an EAR.

      When I build with maven / run from command line, everything works fine.

      But when I run from OEPE using the split source structure (actually also when I run from command-line using the split source structure that OEPE has generated), all the JSF in the JARs are not found anymore, and I get a 404 Error in the browser.

      I can reproduce the problem with a minimal set of almost-empty Eclipse projects (one WebFragment, one WAR, and an autogenerated EAR).

      (too bad I can't attach it here)

      The generated .beabuild.txt is as follows:

      C\:/workspaces/weblogicear/WebFragmentWAR/WebContent = WebFragmentWAR.war
      C\:/workspaces/weblogicear/WebFragmentWAR/build/weboutput = WebFragmentWAR.war
      C\:/workspaces/weblogicear/WebFragmentWAR/build/classes = WebFragmentWAR.war/WEB-INF/classes
      C\:/workspaces/weblogicear/WebFragment/bin = WebFragmentWAR.war/WEB-INF/lib/WebFragment.jar

      Under WebFragment/bin/META-INF/resources I have an index.xhtml, which is not found by Weblogic's implementation of ExternalContext.

      See also this thread (without answer): When web apps/war published via OEPE I get '404 Not found' on access I don't know if the original poster had the same problem. I tried to reply there, but my reply doesn't show up.