This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Sep 16, 2013 8:06 PM by AnshulKaushal RSS

Problem starting Weblogic Server

950016 Newbie
Currently Being Moderated
./startWebLogic.sh
.
.
JAVA Memory arguments: -Xms512m -Xmx512m
.
WLS Start Mode=Development
.
CLASSPATH=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/lib/tools.jar:/wlserver/server/lib/weblogic_sp.jar:/wlserver/server/lib/weblogic.jar:/modules/features/weblogic.server.modules_12.1.1.0.jar:/wlserver/server/lib/webservices.jar:/modules/org.apache.ant_1.7.1/lib/ant-all.jar:/modules/net.sf.antcontrib_1.1.0.0_1-0b2/lib/ant-contrib.jar:/wlserver/common/derby/lib/derbyclient.jar:/wlserver/server/lib/xqrl.jar
.
PATH=/wlserver/server/bin:/modules/org.apache.ant_1.7.1/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/jre/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
.
***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at http://hostname:port/console *
***************************************************
starting weblogic with Java version:
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)
Starting WLS with line:
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -Xms512m -Xmx512m -Dweblogic.Name=AdminServer -Djava.security.policy=/wlserver/server/lib/weblogic.policy -Djava.endorsed.dirs=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/jre/lib/endorsed:/wlserver/endorsed -da -Dplatform.home=/wlserver -Dwls.home=/wlserver/server -Dweblogic.home=/wlserver/server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= weblogic.Server
Exception in thread "main" java.lang.NoClassDefFoundError: weblogic/Server
Caused by: java.lang.ClassNotFoundException: weblogic.Server
     at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
     at java.security.AccessController.doPrivileged(Native Method)
     at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
     at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points