This discussion is archived
1 2 Previous Next 21 Replies Latest reply: Oct 25, 2013 9:36 PM by 35b1eb45-3daf-4dc3-bf15-20b8bc4697b3 RSS

OEPE not compatible with Juno (4.2)

940885 Newbie
Currently Being Moderated
The download packages Eclipse is offering are only the 4.2 builds:
http://www.eclipse.org/downloads/index-developer.php

I've been reading for some time that 4.2 will be the official Juno build. However, OEPE is marked to be only compatible up to 3.8.

Any plans on this being fixed?
  • 1. Re: OEPE not compatible with Juno (4.2)
    kosta Journeyer
    Currently Being Moderated
    For Juno, OEPE will support both 3.8 and 4.2 streams. The distros and installers will be 3.8 based as 4.2 isn't really ready for prime time, but users will be able to install OEPE into a 4.2 install using the provided repository or Eclipse Marketplace.

    It looks like we need to clarify this on the download page.

    Note that OEPE with final Juno support will not be available until some time after Juno ships at the end of June. The latest version currently available (12.1.1.0.1) supports only Juno M6 milestone build (either 3.8 or 4.2 flavor).

    Thanks,

    - Konstantin
  • 2. Re: OEPE not compatible with Juno (4.2)
    940885 Newbie
    Currently Being Moderated
    When I go to the Eclipse Marketplace today, the plugin is described as 12.1.1.0 (not 12.1.1.0.1). It won't let me install it yet due to some conflicting dependencies, but I noticed this line (see my bolding). There's a line that says [3.7.0,3.8.0) -- is that stipulated by the plugin?

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Oracle Enterprise Pack for Eclipse 2.0.1.201203120349 (oracle.eclipse.tools.indigo.oepe.product.feature.group 2.0.1.201203120349)
    Software currently installed: Eclipse IDE for Java EE Developers 1.5.0.20120516-1040 (epp.package.jee 1.5.0.20120516-1040)
    Only one of the following can be installed at once:
    Compare Support for Word 1.0.200.v20111215-1439 (org.eclipse.compare.win32 1.0.200.v20111215-1439)
    Compare Support for Word 1.0.100.I20100505-1245 (org.eclipse.compare.win32 1.0.100.I20100505-1245)
    Compare Support for Word 1.0.200.I20110510-0800 (org.eclipse.compare.win32 1.0.200.I20110510-0800)
    Compare Support for Word 1.0.200.v20120522-1148 (org.eclipse.compare.win32 1.0.200.v20120522-1148)
    Compare Support for Word 1.0.101.R36x_v20101103-0618 (org.eclipse.compare.win32 1.0.101.R36x_v20101103-0618)
    Cannot satisfy dependency:
    From: Eclipse IDE for Java EE Developers 1.5.0.20120516-1040 (epp.package.jee 1.5.0.20120516-1040)
    To: org.eclipse.epp.package.jee.feature.feature.group [1.5.0.20120516-1040]
    Cannot satisfy dependency:
    From: Oracle Enterprise Pack for Eclipse 2.0.1.201203120349 (oracle.eclipse.tools.indigo.oepe.product.feature.group 2.0.1.201203120349)
    To: org.eclipse.platform.feature.group [3.7.0,3.8.0)
  • 3. Re: OEPE not compatible with Juno (4.2)
    kosta Journeyer
    Currently Being Moderated
    You cannot install OEPE into Juno from Eclipse Marketplace yet as Juno support is not a finished product. You are trying to install OEPE plugins for Indigo into Juno, which is expected to fail. There are functional differences between Indigo and Juno. No single version of OEPE is compatible with both.

    To install OEPE into Juno, you will need Juno M6 version. No other milestone build is expected to work, then you need to use the repository that's referenced on 12.1.1.0.1 download page...

    http://download.oracle.com/otn_software/oepe/juno

    Alternatively, just download one of the provided Juno M6 packages from the 12.1.1.0.1 download page...

    http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/oepe-12111-1560492.html

    - Konstantin
  • 4. Re: OEPE not compatible with Juno (4.2)
    946073 Newbie
    Currently Being Moderated
    I have used the link to OEPE discribed above but still get the allready described exception. The Juno-Release is 4.2 and not 3.8. Please correct this problem. The Releasdate of Juno is 27th of July. I think Eclipse is developing on Juno since over a year and the problem to install OEPE is still active. Do you still have interests in OEPE in eclipse ?

    Thank you.

    Edited by: 943070 on Jun 27, 2012 4:09 AM
  • 5. Re: OEPE not compatible with Juno (4.2)
    kosta Journeyer
    Currently Being Moderated
    A version of OEPE with final Juno support will be available some time in mid-July. The above links are for the Juno tech-preview, which is only compatible with Juno M6 builds. In terms of versions of Eclipse, Juno includes both Eclipse 3.8 and Eclipse 4.2 releases. When we release final support for Juno, it will support both versions. Note however that the all-in-one packages will be 3.8-based for stability reasons. To use Eclipse 4.2, users will need to download their own Eclipse and install OEPE from the provided repository or Eclipse Marketplace.

    - Konstantin
  • 6. Re: OEPE not compatible with Juno (4.2)
    950578 Newbie
    Currently Being Moderated
    So now that it is the middle of July, is there any update on getting OEPE working with Juno 4.2? Thanks in advance for any help you can give!
  • 7. Re: OEPE not compatible with Juno (4.2)
    878839 Newbie
    Currently Being Moderated
    I am really looking forward to this as well. I've been playing around with Juno (4.2 flavor) and it's slick. I can't wait to use it in my daily dev.
  • 8. Re: OEPE not compatible with Juno (4.2)
    910274 Newbie
    Currently Being Moderated
    Please publish at least some roadmap of OEPE support for Juno. We tested everything else and we are ok to choose Juno for next project period (1-2 years) except for OEPE. Management needs at least a deadline for decision.
  • 9. Re: OEPE not compatible with Juno (4.2)
    kosta Journeyer
    Currently Being Moderated
    OEPE with Juno support is undergoing final testing. Unfortunately, some issues arose that are delaying the release. We hope to get the release out in the next few weeks, but we cannot disclose a fixed date or any form of "available by" assurance.

    We understand that customers are excited about Juno and are anxious to start using it with OEPE. We appreciate your patience waiting for this release.

    - Konstantin
  • 10. Re: OEPE not compatible with Juno (4.2)
    946073 Newbie
    Currently Being Moderated
    Hello OEPE-developers,

    beware the next eclipse "Kepler" will be released June 26, 2013.

    Mayby this time you can release a new version of OEPE earlier.

    Thank you for your help and support.
  • 11. Re: OEPE not compatible with Juno (4.2)
    910274 Newbie
    Currently Being Moderated
    I wouldn't address developers in any complains. On the contrary, we shoul be glad that Kosta is honest with us - thanks.
  • 12. Re: OEPE not compatible with Juno (4.2)
    953221 Newbie
    Currently Being Moderated
    hey guys, I know you work hard in oepe for a while with juno(4.2), I finally installed the new oepe in my juno, but here comes a new problem:
    When I try to install the Dynamic Web Module in to a project based on weblogic 11gR1, I got the following error:
    Failed while installing Dynamic Web Module 2.5.
    java.lang.String cannot be cast to oracle.eclipse.tools.weblogic.WebLogicServerInstall

    So any advises? Or any solutions? Thank you very much!!
  • 13. Re: OEPE not compatible with Juno (4.2)
    kosta Journeyer
    Currently Being Moderated
    Could you post detailed steps leading up to the error as well as the full stack trace. You can find the stack trace in the Error Log view (Window -> Show View -> Other -> General -> Error Log).

    - Konstantin
  • 14. Re: OEPE not compatible with Juno (4.2)
    gstachni Explorer
    Currently Being Moderated
    Just in case you missed the announcement post at the top of the forum, Oracle Enterprise Pack for Eclipse 12.1.1.1.0 is now GA and includes support for Eclipse Juno (both 3.8 and 4.2). We have produced the standalone zips based on Juno 3.8 or you can use the OEPE Repositories (either downloadable or online) to install into existing Juno 3.8 and 4.2.

    More information on the features of the release can be found in the main OEPE OTN page or this release announcement.

    http://www.oracle.com/us/corporate/press/1723375

    Thanks,
    Greg
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points