This discussion is archived
2 Replies Latest reply: Jul 20, 2012 5:54 AM by 854813 RSS

Solaris 10_x86(64bit) VM --  ulimit changes do not survive a reboot

854813 Newbie
Currently Being Moderated
I originally resurrected an older abandoned thread:
make ulimit changes permanent
but a kind forum moderator has split my post away so that it stands on its own merits instead of distracting from that person's earlier issue.

My issue is ...
----

I am in need of changing the default stack size as reported by ulimit -s on a Solaris 10 x86_64 VM however the changes suggested to /etc/system do nothing on reboot to what is reported by ulimit -s.

My current ulimit -s is 10240 but according to the oracle 11g installation docs on page 2-19 (Configure Shell Limits) they recommend you change the value reported by ulimit -s to be 32k (or 32768).

Putting the following in /etc/system does nothing to that value after a reboot:

set lwp_default_stksize=0x8000

I also tried:

set lwp_default_stksize=32768

as according to the documentation it is an integer value. Same result though...eg: no change to the value of ulimit -s after reboot.
http://docs.oracle.com/cd/E19455-01/816-0607/6m735r5f7/index.html

What cold the problem be?
  • 1. Re: Solaris 10_x86(64bit) VM --  ulimit changes do not survive a reboot
    bobthesungeek76036 Pro
    Currently Being Moderated
    You are comparing apples to oranges. lwp_default_stksize defines the <b>kernel</b> stack size. ulimit -s defines the process stack size and each process has it's own stack.

    The way I handle it is I have a /etc/init.d/oracle init script that starts the Oracle DBs. In the script I have these lines at the top:

    <pre>ulimit -n 4096
    ulimit -s unlimited</pre>

    And the same in the oracle owner's .profile. Seems to work for me.

    On my Linux hosts, I have the following code in the Oracle init.d script and the oracle owner .bashrc:

    <pre>##########
    # increase limits to hard limits for maxmem, maxmemlock, stacksize,
    # nfiles, nprocmax
    ##########
    declare -a ULIMITLST=(-m -l -s -n -u)
    for i in ${ULIMITLST[@]}
    do
    ulimit $ `ulimit ${i} -H`
    done</pre>
  • 2. Re: Solaris 10_x86(64bit) VM --  ulimit changes do not survive a reboot
    854813 Newbie
    Currently Being Moderated
    I was only going by what another thread in these forums was saying to do for the same thing. So, obviously it was wrong in that thread but the OP never came back to say it was or was not working for him after making the entries in /etc/system...plus the poster of the "answer" seemed sure this was the thing to do. It had also occurred to me to use .profile or the init script but I just wasn't sure that was the right thing to do because of the (misleading) other post.

    Thank you for the clarification. I will use the .profile/init.d script method for changing the ulimit instead.