This discussion is archived
1 Reply Latest reply: Jul 20, 2012 3:15 PM by 923344 RSS

Cloud Control 12c is way slower than 11G Grid Control

ErikaWhittome Newbie
Currently Being Moderated
Is anyone else experiencing slow performance for 12C Cloud Control? My RedHat5 machine has 6Gb memory which should be enough. Every single screen on my browser takes at least 10 seconds to appear. The memory usage on the OEM machine is very high (mainly java items appearing in "top"). I've even applied the BP1, but no improvement at all to performance.

Edited by: ErikaWhittome on Apr 17, 2012 12:33 PM
  • 1. Re: Cloud Control 12c is way slower than 11G Grid Control
    923344 Newbie
    Currently Being Moderated
    I created an SR on this for 12c on Solaris platform (at that time BP1 was not available for Solaris) and got the following advice from Oracle.

    -- Increase Heap Size

    Take a backup of file
    {EM_CONFIG_HOME}/user_projects/domains/<domain_name>/bin/startEMServer.sh
    where
    {EM_CONFIG_HOME}/user_projects/domains/<domain_name> is the Weblogic domain directory, typically gc_inst/user_projects/domains/GCDomain.

    Modify / Add the following lines to startEMServer.sh before the invocation of startWeblogic.sh command:

    USER_MEM_ARGS="-Xms1536m -Xmx1536m -XX:CompileThreshold=8000 -XX:PermSize=768m -XX:MaxPermSize=768m -XX:+HeapDumpOnOutOfMemoryError"

    Re-start OMS by using:
    <OMS_HOME>/bin/emctl stop oms -all
    <OMS_HOME>/bin/emctl start omsow the


    To increase Stuck Thread Max Size.
    ---------------------------------

    1. Go to Environment ->Servers
    2. Select the server EMGC_OMS1
    3. Select Tuning Tab.
    4. Increase the Parameter Stuck Thread Max Time that by default is 600. Increase it in a 30% for triage.
    5. If issue is not resolved, keep increasing on increments of 10%.



    To increase Maximum Connection Pool Size.
    ----------------------------------------

    1. Go to services -> JDBC -> Datasources.
    2. Select the datasource related with EM/Grid Control
    3. Go to Connection Pool Tab
    4. Under Maximum Capacity option, increase the size that by default is 15. Increase it in a 25%
    5. Click on save
    6. If issue is not resolved, keep increasing on increments of 10%.

    Also I found in weblogic tuning advice that it is better to keep setting the InitialCapacity value equal to the MaxCapacity attribute's default production mode.

    Now I got a Linux server and am in the process of installing 12c BP1 and see how it goes.

    I will be interested in knowing how your performance stacks up with these changes....

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points