9 Replies Latest reply: Jul 21, 2012 1:33 PM by Hussein Sawwan-Oracle RSS

    cloning failed in Oracle EBS 11i

    Mahender-OC
      Hi All,

      I have faced one issue while doing cloning ..

      while running adcfgclone.pl on appsTier the scripts struck or hangs at ADX Database Utility.

      and i cancelled after sometime than ran once again but no use and getting failed when Generate Tns Names...


      log shows like below.....
      ##########################################################################
      Generate Tns Names
      ##########################################################################
      Logfile: /oracle/apps/TEST/testappl/admin/TEST_oraapps02/log/06201413/NetServiceHandler.log
      Classpath : /oracle/apps/TEST/testcomn/util/java/1.4/j2sdk1.4.2_04/jre/lib/rt.jar:/oracle/apps/TEST/testcomn/util/java/1.4/j2sdk1.4.2_04/lib/dt.jar:/oracle/apps/TEST/testcomn/util/java/1.4/j2sdk1.4.2_04/lib/tools.jar:/oracle/apps/TEST/testcomn/java/appsborg2.zip:/oracle/apps/TEST/testcomn/java

      Updating s_tnsmode to 'generateTNS'
      UpdateContext exited with status: 0


      Result : FAILED
      ===========================================================================

      Ending Context Value Management System.
      ===========================================================================
      ===========================================================================
      Uploading file system Context file and its templates to the database


      Context file :
      /oracle/apps/TEST/testappl/admin/TEST_oraapps02.xml

      ---------------------------------------------------------------
      ADX Database Utility
      ---------------------------------------------------------------

      getConnectionUsingAppsJDBCConnector() -->
      APPS_JDBC_URL=''
      Trying to get connection using SID based connect descriptor
      getConnection() -->
      sDbHost : oraapps02
      sDbDomain : emri.net
      sDbPort : 1528
      sDbSid : TEST
      sDbUser : APPS
      Trying to connect using SID...
      getConnectionUsingSID() -->
      JDBC URL: jdbc:oracle:thin:@oraapps02.emri.net:1528:TEST
      Connection obtained

      -------------------ADX Database Utility Finished---------------

      =============================================================

      please resolve this issue...
      Thanks in Advance.....
        • 1. Re: cloning failed in Oracle EBS 11i
          509401
          Hi

          Can you let us know the Oracle E-Business Suite, database release and operating system.

          Regards
          Ali
          • 2. Re: cloning failed in Oracle EBS 11i
            Hussein Sawwan-Oracle
            I have faced one issue while doing cloning ..

            while running adcfgclone.pl on appsTier the scripts struck or hangs at ADX Database Utility.
            Do you have the latest Rapid Clone and Autoconfig patches applied?
            and i cancelled after sometime than ran once again but no use and getting failed when Generate Tns Names...
            Have you tried to bounce the services (or the server if possible) and check then?

            Can you find any errors in the database log file?

            Thanks,
            Hussein
            • 3. Re: cloning failed in Oracle EBS 11i
              Mahender-OC
              Hi,

              Oracle EBS version is 11.5.10.2 and database version is 9.2.0.6,
              RedHat LINUX 4.

              While running sh autoconfig also getting hangs at the stage of ..
              AutoConfig Services Phase
              Running Service Process 10 of 12 for AD_TOP
              Executing script in InstantiateFile:
              /oracle/apps/TEST/testora/iAS/Apache/perl/bin/perl -I /oracle/apps/TEST/testora/iAS/Apache/perl/lib/5.00503 -I /oracle/apps/TEST/testora/iAS/Apache/perl/lib/site_perl/5.005 -I /oracle/apps/TEST/testappl/au/11.5.0/perl /oracle/apps/TEST/testcomn/admin/install/TEST_oraapps02/adupdlobs.pl

              after stopped the listener database also not shutting down immediate while running shut immediate it was taking very long time to down..
              alert log shows like below

              Shutting down instance: further logons disabled
              Shutting down instance (immediate)
              License high water mark = 5
              wait here only......
              please tell me how to resolve this????

              Thanks in Advance...

              Edited by: 865955 on Jun 21, 2012 2:55 PM
              • 4. Re: cloning failed in Oracle EBS 11i
                Hussein Sawwan-Oracle
                Please see (Autconfig Takes a Very Long Time To Run On adupdlobs.pl [ID 404334.1]).

                Thanks,
                Hussein
                • 5. Re: cloning failed in Oracle EBS 11i
                  Mahender-OC
                  Hi Hussein,

                  Thanks for reply and i followed solution as per the above but queries fails with below errors..

                  SQL> conn applsys/apps
                  Connected.
                  SQL> ALTER INDEX fnd_lobs_ctx REBUILD;
                  ALTER INDEX fnd_lobs_ctx REBUILD
                  *
                  ERROR at line 1:
                  ORA-29868: cannot issue DDL on a domain index marked as LOADING


                  [appltest@oraapps02 TEST_oraapps02]$ sqlplus 'apps/apps'

                  SQL*Plus: Release 8.0.6.0.0 - Production on Mon Jun 25 10:04:24 2012

                  (c) Copyright 1999 Oracle Corporation. All rights reserved.


                  Connected to:
                  Oracle9i Enterprise Edition Release 9.2.0.6.0 - Production
                  With the Partitioning, OLAP and Oracle Data Mining options
                  JServer Release 9.2.0.6.0 - Production

                  SQL>
                  SQL> @adupdlobs.sql apps apps TEST
                  Connected.
                  declare
                  *
                  ERROR at line 1:
                  ORA-29861: domain index is marked LOADING/FAILED/UNUSABLE
                  ORA-06512: at line 39
                  ORA-06512: at line 94


                  Disconnected from Oracle9i Enterprise Edition Release 9.2.0.6.0 - Production
                  With the Partitioning, OLAP and Oracle Data Mining options
                  JServer Release 9.2.0.6.0 - Production


                  please tell me how to resolve this?

                  and i have tried with fresh rapid clone but same issue is running autoconfig fails or hangs at the script called adupdlobs.p...

                  after sometime i have tried to run autoconfig on both tiers after bounce the DATABASE first on dbTier unfortunately autocnfig successfully completed on the both nodes..
                  after i have started all services and but not getting login page and i tried to bounce the services after hitting adstpall.sh it was hangs and not go down.

                  even after sometime i kill all process manually bounce the database and start the services
                  but unable to get login page....

                  please give me reply with solution...

                  Thanks for your support .............

                  Edited by: 865955 on Jun 25, 2012 4:53 PM
                  • 6. Re: cloning failed in Oracle EBS 11i
                    Hussein Sawwan-Oracle
                    after sometime i have tried to run autoconfig on both tiers after bounce the DATABASE first on dbTier unfortunately autocnfig successfully completed on the both nodes..
                    Do you mean you managed to resolve ORA-29868 error?
                    after i have started all services and but not getting login page and i tried to bounce the services after hitting adstpall.sh it was hangs and not go down.

                    even after sometime i kill all process manually bounce the database and start the services
                    but unable to get login page....
                    What is the status of the application services? Are they up and running?

                    What is the error you get?

                    Please check Apache log files for details about the error.

                    Thanks,
                    Hussein
                    • 7. Re: cloning failed in Oracle EBS 11i
                      Mahender-OC
                      Hi Hussein,

                      Thanks for quick reply...

                      No,not resolved the ORA-29868 error...
                      it is showing the status ' INPROGRES' like below..
                      SQL> select INDEX_NAME,TABLE_OWNER,status from dba_indexes where INDEX_TYPE = 'DOMAIN';
                      INDEXNAME_ TABLEOWNER_ STATUS
                      FND_LOBS_CTX APPLSYS INPROGRS

                      The Application services are up but not to down while ran adstpal.sh and hitting adcmctl.sh status also getting hanged

                      Apache access log shows
                      192.168.1.92 - - [26/Jun/2012:10:23:18 +0530] "GET /oa_servlets/AppsLogin HTTP/1.0" 302 402 0
                      192.168.1.92 - - [26/Jun/2012:10:28:19 +0530] "GET /OA_HTML/AppsLocalLogin.jsp?requestUrl=APPSHOMEPAGE&cancelUrl=http%3A%2F%2Foraapps02.emri.net%3A8007%2Foa_servlets%2Foracle.apps.fnd.sso.AppsLogin&s2=2F0661EC39AA894C26357603E9A4C39BB91731820FB8349DCC2E448C215A69B0 HTTP/1.0" 200 - 301
                      192.168.1.92 - - [26/Jun/2012:10:39:09 +0530] "GET /oa_servlets/AppsLogin HTTP/1.0" 302 402 0
                      error log shows
                      [Tue Jun 26 10:17:11 2012] [error] [client 192.168.1.92] (36)File name too long: access to /redirectURL$url=http_3A$|$|oraapps02.emri.net_3A8007$|oa*servlets$|oracle.apps.fnd.sso.AppsLogin3FrequestUrl$=$|oa*servlets$|weboam$|oam$|oamLogin26cancelUrl$=http_3A$|$|oraapps02.emri.net_3A8007$|oa*_servlets$|oracle.apps.fnd.sso.AppsLogin$forward=oam$|oamLogin failed

                      Thanks..
                      • 8. Re: cloning failed in Oracle EBS 11i
                        Mahender-OC
                        Check the database archive log mode and conform it
                        • 9. Re: cloning failed in Oracle EBS 11i
                          Hussein Sawwan-Oracle
                          No,not resolved the ORA-29868 error...
                          it is showing the status ' INPROGRES' like below..
                          SQL> select INDEX_NAME,TABLE_OWNER,status from dba_indexes where INDEX_TYPE = 'DOMAIN';
                          INDEXNAME_ TABLEOWNER_ STATUS
                          FND_LOBS_CTX APPLSYS INPROGRS
                          You can rebuild the index.

                          Applying Patch 5055050 or 9239090 FNDGFU fails: ORA-29861 Domain Index Is Marked Loading/Failed/Unusable Ora-29861 [ID 373187.1]
                          PO Approval: Purchase Orders In Process With ORA-29861 Error In Activity: DELETE_PDF_ATTACHMENTS [ID 887145.1]
                          The Application services are up but not to down while ran adstpal.sh and hitting adcmctl.sh status also getting hanged
                          Did you run AutoConfig successfully?

                          Thanks,
                          Hussein