This discussion is archived
1 Reply Latest reply: Jul 30, 2012 9:27 AM by 817614 RSS

Java 7u5 webstart can not start JNLP for jre1.4

user10164206 Newbie
Currently Being Moderated
I have a web start application on jre1.4.

When I start the application on (OS: Wind XP jre: jre1.7u5 +jre1.4_19), AN error occurred.
but on (OS: Wind XP jre: jre1.6u33 +jre1.4_19),  The  application can be started normally.

this is the err message.
java.lang.NoSuchMethodError: java.lang.Integer.valueOf(I)Ljava/lang/Integer;

     at com.sun.deploy.net.DownloadEngine.incrementInternalUse(Unknown Source)

     at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)

     at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

     at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

     at com.sun.javaws.Launcher.launch(Unknown Source)

     at com.sun.javaws.Main.launchApp(Unknown Source)

     at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

     at com.sun.javaws.Main$1.run(Unknown Source)

     at java.lang.Thread.run(Unknown Source)


This is my jnlp file.

<?xml version="1.0" encoding="utf-8"?>
<jnlp spec="1.0+" codebase="http://xxxx02:8001/csec">
<information>
<title>Tri-Trade
</title>
<vendor>xxxxxxxxx</vendor>
<description>xxxxx.
</description>
<description kind="short">xxxxxx.
</description>
<icon href="images/Logo_Blue2.gif" kind="default" depth="256" size="64" width="64" height="64"/>
<icon href="images/Logo.gif" kind="splash"/>
</information>
<resources>
<j2se version="1.4.2_19" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_18" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_17" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_16" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_15" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_14" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_13" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_12" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_11" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_10" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_09" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<j2se version="1.4.2_08" href="http://java.sun.com/products/autodl/j2se" java-vm-args="-Xms128m -Xmx128m" />
<property name="java.security.policy" value="http://xxxxxx:8001/csec/java.policy"/>
<property name="USERID" value="demo"/>
<property name="USERPASSWORD" value="C514C91E4ED341F263E458D44B3BB0A7"/>
<property name="USERLOCALE" value="ja_JP"/>
<property name="weblogic.corba.client.bidir" value="true"/>
<jar href="csecPtsCustomer.jar"/>
<jar href="commons-lang-2.0.jar"/>
<jar href="log4j-1.2.14.jar"/>
<jar href="xxxxxx.jar"/>
<jar href="wljmsclient.jar"/>
<jar href="wlclient.jar"/>
</resources>
<security>
<all-permissions/>
</security>
<application-desc main-class="jp.co.xxxxx.web.pts.customer.main.Main">
</application-desc>
</jnlp>

Edited by: user10164206 on 2012/07/29 19:54

Edited by: user10164206 on 2012/07/30 2:20

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points