7 Replies Latest reply: Aug 24, 2012 11:40 PM by 638153 RSS

    Candidate ASM disks not showing

    805285
      Hi all,

      I am installing a 2 node RAC configuration on two Linux RHEL5 machines. I am in the middle of the GRID installation, at the "Create ASM Disks" window....and it is showing no disks.

      I am using HP multipath technology, so my disks are like /dev/mapper/mpath1....mpath2...and so on.

      I have already used the /usr/sbin/oracleasm commands to configure and create the candidate disks and they are showing at the "/usr/sbin/oracleasm listdisks" command output:

      # /usr/sbin/oracleasm listdisks
      CLUSTER_ORA_DATA
      CLUSTER_ORA_FRA
      CLUSTER_ORA_REPO

      The disks show with the root and with the oracle user. I am using the oracle user to install GRID. I have also changed the Discovery Path to "/dev/mapper/mpath1" or just "/dev/mapper" and no disk appears....

      What is missing?

      Any help is appreciated.
      Mario
        • 1. Re: Candidate ASM disks not showing
          805285
          Hi all again....

          I did some research on the good and old Google and found out what I was doing wrong......turns out the the Discovery Path is not the actual OS path for the disks, but "/dev/oracleasm/disks/*".......

          Thanks anyway.

          Mario
          • 2. Re: Candidate ASM disks not showing
            508355
            Hi mario,
            Can you help me on the same issue.
            I am trying to implement oracle10g RAC using vmware on OEL4update 7 on my laptop lenovo SL400.


            My shared Harddisks
            ------------------------------
            $ su -
            # /etc/init.d/oracleasm createdisk VOL1 /dev/sdc1
            Marking disk "/dev/sdc1" as an ASM disk [  OK  ]

            # /etc/init.d/oracleasm createdisk VOL2 /dev/sdd1
            Marking disk "/dev/sdd1" as an ASM disk [  OK  ]

            # /etc/init.d/oracleasm createdisk VOL3 /dev/sde1
            Marking disk "/dev/sde1" as an ASM disk [  OK  ]

            # /etc/init.d/oracleasm createdisk VOL4 /dev/sdf1
            Marking disk "/dev/sdf1" as an ASM disk [  OK  ]


            Create asm disks:
            ----------------------------
            [oracle@vmlinux1 dbca]$ /etc/init.d/oracleasm listdisks
            VOL1
            VOL2
            VOL3
            VOL4


            I have installed ORACLE clusterware,Oracle 10g software in 2 nodes which was created in the laptop using VMware workstation 6.

            As I am about to create the cluster database with storage option as ASM.

            in DBCA --> ASM DISK groups i have to create disk as there no disk group exist.


            [root@vmlinux1 dev]# ls -l sd*
            brw-rw---- 1 root disk 8, 0 Dec 17 11:48 sda
            brw-rw---- 1 root disk 8, 1 Dec 17 11:48 sda1
            brw-rw---- 1 root disk 8, 2 Dec 17 11:48 sda2
            brw-rw---- 1 root disk 8, 16 Dec 17 11:48 sdb
            brw-rw---- 1 root disk 8, 17 Dec 17 11:48 sdb1
            brw-rw---- 1 root disk 8, 32 Dec 17 11:48 sdc
            brw-rw---- 1 root disk 8, 33 Dec 17 11:52 sdc1
            brw-rw---- 1 root disk 8, 48 Dec 17 11:48 sdd
            brw-rw---- 1 root disk 8, 49 Dec 17 11:52 sdd1
            brw-rw---- 1 root disk 8, 64 Dec 17 11:48 sde
            brw-rw---- 1 root disk 8, 65 Dec 17 11:52 sde1
            brw-rw---- 1 root disk 8, 80 Dec 17 11:48 sdf
            brw-rw---- 1 root disk 8, 81 Dec 17 11:52 sdf1


            note:

            when I try to create disk group I have not been give disk member.I clicked change disk discovery path, but still I didnot find any disk

            what might have gone wrong. Can you help me on this with the details I have provided to you.




            Thanks & Regards,
            Omprakash
            om.prakash.in@gmail.com
            • 3. Re: Candidate ASM disks not showing
              875915
              The problem could also be that you are entering the wrong ASM password.
              • 4. Re: Candidate ASM disks not showing
                877440
                How did you resolve your issue? I had exact same issue now. my disks are under /dev/mapper also .

                Now the candidate ASM DISKS are not showing...

                Please help us resolve this issue.

                Thanks
                • 5. Re: Candidate ASM disks not showing
                  918424
                  Mario: I feel very grateful to you Mario for being in this roll of honour even though you got the answer yourself, you have posted it for others sake. This helps me today and will be helpful for more and more folks.

                  Keep it up mate..

                  CheerS..!!


                  Vimal.
                  • 6. Candidate ASM disks not showing up in installer.
                    JDinPA
                    I see this thread is answered so I'll create a new thread.
                    • 7. Re: Candidate ASM disks not showing
                      638153
                      answer was the exact match and it solved my problem smoothly

                      thanks

                      asif