This discussion is archived
2 Replies Latest reply: Aug 17, 2013 2:09 PM by 93b10c1b-9c68-46c8-b92c-e781af1a5b30 RSS

JMS Issues with weblogic 10.3.5

906074 Newbie
Currently Being Moderated
Hi All,

We are facing an issue with weblogic 10.3.5 where the JMS messages are being produced and consumed. But these messages doesnt seem to be getting processed at all. This is a very random behaviour but is very consistent. We have OIM deployed and the database is a gridlink based. The following are the JMS messages I can see which are produced and consumed:

####<Aug 2, 2012 10:06:12 PM EST> <BEA1-7DEA0ED585CF4B756914-574C53746F72655F49414D5F4F494D4A4D5346696C6553746F72655F6175746F5F31> <> <1343909172663> <39120> <ID:<836012.1343909172656.0>> <> <OIMJMSModule!OIMJMSServer_auto_1@dist_oimProcessQueue_auto> <Produced> <xelsysadm> <> <<?xml version="1.0" encoding="UTF-8"?>
<mes:WLJMSMessage xmlns:mes="http://www.bea.com/WLS/JMS/Message"><mes:Header><mes:JMSDeliveryMode>PERSISTENT</mes:JMSDeliveryMode><mes:JMSExpiration>0</mes:JMSExpiration><mes:JMSPriority>4</mes:JMSPriority><mes:JMSRedelivered>false</mes:JMSRedelivered><mes:JMSTimestamp>1343909172656</mes:JMSTimestamp><mes:Properties><mes:property name="JMS_BEA_RedeliveryLimit"><mes:Int>1</mes:Int></mes:property><mes:property name="JMSXDeliveryCount"><mes:Int>0</mes:Int></mes:property></mes:Properties></mes:Header></mes:WLJMSMessage>> <>

####<Aug 2, 2012 10:06:12 PM EST> <> <> <1343909172720> <118199> <ID:<836012.1343909172656.0>> <> <OIMJMSModule!OIMJMSServer_auto_1@dist_oimProcessQueue_auto> <Consumed> <oiminternal> <MC:CA(local):OAMI(oimServer1.jms.connection25.session911.consumer922)> <<?xml version="1.0" encoding="UTF-8"?>
<mes:WLJMSMessage xmlns:mes="http://www.bea.com/WLS/JMS/Message"><mes:Header><mes:JMSDeliveryMode>PERSISTENT</mes:JMSDeliveryMode><mes:JMSExpiration>0</mes:JMSExpiration><mes:JMSPriority>4</mes:JMSPriority><mes:JMSRedelivered>false</mes:JMSRedelivered><mes:JMSTimestamp>1343909172656</mes:JMSTimestamp><mes:Properties><mes:property name="JMS_BEA_RedeliveryLimit"><mes:Int>1</mes:Int></mes:property><mes:property name="JMSXDeliveryCount"><mes:Int>1</mes:Int></mes:property></mes:Properties></mes:Header></mes:WLJMSMessage>> <>


Please let me know if there is any particular configuration in weblogic I should look at to solve this problem. This is very critical.

Please let me know.

Thanks,
Vishnu
  • 1. Re: JMS Issues with weblogic 10.3.5
    murali veligeti - oracle Expert
    Currently Being Moderated
    Hi Vishnu,

    JMS message processing depends on the business task that is being modeled. As you are observing the behaviour sporadically could you please check whether you are using message selector in your MDB and the messages which are not getting processed are not belogs to that message selector.

    Thanks & Regards,
    Murali.
    ============
  • 2. Re: JMS Issues with weblogic 10.3.5
    93b10c1b-9c68-46c8-b92c-e781af1a5b30 Newbie
    Currently Being Moderated

    Hi,

     

    i am facing some issue while pushing messages into my JMS queues.

    Scenario :

    whenever a new request hits my system, I logged the input message into a queue using publish activity[a proxy service is listening to the queue which persist the queue message into DB]. But during the peak hours the no requests are so high that the publish activity which i am using to post the message into the queue didn't work because no it is unable to find the any available queue to post the message. i have used clustering in server to avoid the issue.

    any solution for this problem ??

     

    Thanks & Regards,

    Kuldeep

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points