This discussion is archived
9 Replies Latest reply: Aug 5, 2012 4:58 AM by user769080 RSS

Administration Server could not be reached

user769080 Newbie
Currently Being Moderated
I have installed WebLogic 12c on a WinXP machine and configured a domain in development mode. Apart from the admin server there is only one managed server ms1.
By using the startup scripts I am successfully able to start both AdminServer and ms1 and access the console.

Then I enabled SSL ports on both AdminServer & ms1, enabled the domain Administration port, and overrode Local Administration Port for ms1.
The different port values are:

Administration Port = 9002
AdminServer (Listen Port = 7001, SSL Listen Port = 7002, Local Administration Port Override = 9002)
ms1 (Listen Port = 7011, SSL Listen Port = 7012, Local Administration Port Override = 9012)

Then I am able to start AdminServer from startWebLogic and it duly shows:
<Notice> <Server> <BEA-002613> <Channel "DefaultAdministration" is now listening on 127.0.0.1:9002 for protocols admin, ldaps, https.>
Also able to access the console at this point.

However then when I try to start ms1 using startManagedWebLogic.cmd ms1 https://127.0.0.1:9002 it is not able to connect to the admin server:
<Emergency> <Management> <BEA-141151> <The Administration Server could not be reached at https://127.0.0.1:9002.>
<Info> <Configuration Management> <BEA-150018> <This server is being started in Managed Server independence mode in the absence of the Administration Server.>

As mentioned before I am able to access the console from https://localhost:9002/console and netstat output shows:
TCP 127.0.0.1:9002 0.0.0.0:0 LISTENING
TCP 127.0.0.1:9002 127.0.0.1:3040 ESTABLISHED
TCP 127.0.0.1:9002 127.0.0.1:3042 ESTABLISHED

What could be the reason that while starting up ms1 is not able to connect to AdminServer on 9002? But all is fine when the administration port is not enabled.

Any help on this is much appreciated. Thanks!
  • 1. Re: Administration Server could not be reached
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,

    Try to start your managed server using following way.

    startManagedWebLogic.sh t3s://<AdminURL -IP address>:<ssl-port

    This way you can able to start your managed server with out any issue.

    Regards,
    Kal
  • 2. Re: Administration Server could not be reached
    768154 Newbie
    Currently Being Moderated
    Try to start like below:

    startManagedWebLogic.cmd myManagedServer https://AdminHost:9002
  • 3. Re: Administration Server could not be reached
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    can you please try t3s instead of https.

    Regards,
    Kal
  • 4. Re: Administration Server could not be reached
    user769080 Newbie
    Currently Being Moderated
    Thanks for your suggestions, I tried starting with:
    startManagedWebLogic.cmd ms1 t3s://127.0.0.1:9002
    and also
    startManagedWebLogic.cmd ms1 t3s://localhost:9002
    but still getting the same error:
    <Emergency> <Management> <BEA-141151> <The Administration Server could not be reached at https://127.0.0.1:9002.>
    <Info> <Configuration Management> <BEA-150018> <This server is being started in Managed Server independence mode in the absence of the Administration Server.>

    From the Admin Console I can see that the Administration Protocol for the domain is set as t3s.

    The netstat output is showing that it is listening on 9002:
    TCP 127.0.0.1:7001 0.0.0.0:0 LISTENING
    TCP 127.0.0.1:7002 0.0.0.0:0 LISTENING
    TCP 127.0.0.1:7011 0.0.0.0:0 LISTENING
    TCP 127.0.0.1:7012 0.0.0.0:0 LISTENING
    TCP 127.0.0.1:9002 0.0.0.0:0 LISTENING
    TCP 127.0.0.1:9002 127.0.0.1:3330 ESTABLISHED
    TCP 127.0.0.1:9012 0.0.0.0:0 LISTENING

    What else can I try so that the managed server does not start up in MSI mode?
  • 5. Re: Administration Server could not be reached
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,

    Can you check your config.xml file file.

    Look for Listen-Adress for AdminServer make sure that you have given your IP address or localhost.

    If there is any specific address is there then remove it to use localhost or 12.0.0.1 URL.

    also check the port number for Admin server in listen-port and ssl listen port.

    if you dont see any listen port then mean it is using default port which is 7001.

    Still if you have query let me know.

    Regards,
    Kal
  • 6. Re: Administration Server could not be reached
    user769080 Newbie
    Currently Being Moderated
    Hello,

    The problem still persists. I even tried changing a few of the port values and also the administration protocol to https from t3s but they didn't help.
    This is how the config.xml looks now:

    ...
    <server>
    <name>AdminServer</name>
    <ssl>
    <enabled>true</enabled>
    <hostname-verifier xsi:nil="true"></hostname-verifier>
    <hostname-verification-ignored>true</hostname-verification-ignored>
    <client-certificate-enforced>false</client-certificate-enforced>
    <listen-port>7004</listen-port>
    <two-way-ssl-enabled>false</two-way-ssl-enabled>
    </ssl>
    <listen-port>7003</listen-port>
    <listen-address>127.0.0.1</listen-address>
    <administration-port>9003</administration-port>
    </server>
    <server>
    <name>ms1</name>
    <ssl>
    <enabled>true</enabled>
    <hostname-verifier xsi:nil="true"></hostname-verifier>
    <hostname-verification-ignored>true</hostname-verification-ignored>
    <client-certificate-enforced>false</client-certificate-enforced>
    <listen-port>7012</listen-port>
    <two-way-ssl-enabled>false</two-way-ssl-enabled>
    </ssl>
    <machine xsi:nil="true"></machine>
    <listen-port>7011</listen-port>
    <cluster xsi:nil="true"></cluster>
    <web-server>
    <web-server-log>
    <number-of-files-limited>false</number-of-files-limited>
    </web-server-log>
    </web-server>
    <listen-address>127.0.0.1</listen-address>
    <administration-port>9012</administration-port>
    </server>
    ...
    <administration-port-enabled>true</administration-port-enabled>
    <administration-port>9003</administration-port>
    <configuration-version>12.1.1.0</configuration-version>
    <admin-server-name>AdminServer</admin-server-name>
    <administration-protocol>https</administration-protocol>
  • 7. Re: Administration Server could not be reached
    user769080 Newbie
    Currently Being Moderated
    Now I tried following the same steps of installation & configuration on a Linux machine and still getting the same message while starting the managed server:

    <Emergency> <Management> <BEA-141151> <The Administration Server could not be reached at https://myhost.mydomain.com:45703.>
    <Info> <Configuration Management> <BEA-150018> <This server is being started in Managed Server independence mode in the absence of the Administration Server.>

    For this domain the ports are:
    AdminServer (default=45701, ssl=45702, admin=45703)
    ms1 (default=45711, ssl=45712, admin=45713)

    As has been suggested here I have tried with protocol t3s also but that didn't help.

    I have been using the 183MB zip distribution of 12c for installing on both the WinXP machine before and on Linux now.
    As like before I am able to access the console from https://myhost.mydomain.com:45703

    Any ideas will be most helpful.

    Thanks!
  • 8. Re: Administration Server could not be reached
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,

    As you I see that Admin server port is 7004 and SSL port is 7003 but your App is looking different port so which external suite you are using it required slight changes with in configuration there to access your Admin server.

    Regards,
    Kal
  • 9. Re: Administration Server could not be reached
    user769080 Newbie
    Currently Being Moderated
    To clarify I have made two similar configurations in two different environments - first Windows and then Linux.
    For the domain on Windows the ports are 70** & 90**, while for the domain on Linux the ports are 457**.

    While starting the managed server after enabling admin port, the message from both these environments are the same ie., not able to connect to admin server on https://adminhost:adminport.

    What is it that's wrong in these configurations?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points