1 Reply Latest reply: Aug 3, 2012 5:52 AM by Sebastian Solbach -Dba Community-Oracle RSS

    Oracle VM Server 3.1.1 RAC Templates

    LeightonLNelson
      I'm trying to build a 2-node RAC using the OVM Server 3.1.1 RAC templates using the deploycluster method but I'm hitting an issue where the VMs are failing to start. I get the same error for both VMs.

      ERROR: Failed to start VM (with a simple name of "racnode.0") due to an exception (retried 1 time) (first 4 lines of exception; see output below):
      java.lang.Exception: com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_4010E Attempt to send command: dispatch to server: ovmserver1 failed. OVMAPI_4004E Server Failed Command: dispatch https://?uname?:?pwd?@192.168.56.101:8899/api/2 start_vm 0004fb000003000013735cc530189395 0004fb0000060000221fdd3833546119, Status: org.apache.xmlrpc.XmlRpcException: exceptions.RuntimeError:Command: ['xm', 'create', '/OVS/Repositories/0004fb000003000013735cc530189395/VirtualMachines/0004fb0000060000221fdd3833546119/vm.cfg'] failed (1): stderr: Error: Device 51728 (vbd) could not be connected. /etc/xen/scripts/block failed; error detected.
      stdout: Using config file "/OVS/Repositories/0004fb000003000013735cc530189395/VirtualMachines/0004fb0000060000221fdd3833546119/vm.cfg".

      Here's the vm.cfg file:

      [root@ovmserver1 ~]# cat /OVS/Repositories/0004fb000003000013735cc530189395/VirtualMachines/0004fb0000060000221fdd3833546119/vm.cfg
      vif = ['mac=00:21:f6:00:00:0a,bridge=0004fb00103c6db', 'mac=00:21:f6:00:00:00,bridge=0004fb00103c6db']
      OVM_simple_name = 'racnode.0'
      disk = ['file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb0000120000dc726b6cdf420f01.img,xvda,w', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb0000120000d3f9422fae0baf39.img,xvdb,w', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb00001200003982335235405e10.img,xvdc,w!', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb000012000002eb285a7e341ba5.img,xvdd,w!', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb0000120000be75a57f53f37808.img,xvde,w!', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb00001200008de9401ee570ffd2.img,xvdf,w!', 'file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb0000120000440f299e297193f2.img,xvdg,w!']
      uuid = '0004fb00-0006-0000-221f-dd3833546119'
      on_reboot = 'restart'
      cpu_weight = 27500
      memory = 1700
      cpu_cap = 0
      maxvcpus = 1
      OVM_high_availability = False
      maxmem = 1700
      OVM_description = ''
      on_poweroff = 'destroy'
      on_crash = 'restart'
      bootloader = '/usr/bin/pygrub'
      name = '0004fb0000060000221fdd3833546119'
      guest_os_type = 'linux'
      vif_other_config = []
      vfb = ['type=vnc,vncunused=1,vnclisten=127.0.0.1,keymap=en-us']
      vcpus = 1
      OVM_os_type = 'Oracle Linux 6'
      OVM_cpu_compat_group = ''
      OVM_domain_type = 'xen_pvm'

      -----End vm.cfg-------------

      Here's my netconfig.ini file:


      [ovm@ovmmanager deploycluster]$ cat netconfig.ini
      # Node specific information
      NODE1=rac1
      NODE1IP=192.168.1.221
      NODE1PRIV=rac1-priv
      NODE1PRIVIP=10.10.10.221
      NODE1VIP=rac1-vip
      NODE1VIPIP=192.168.1.223
      NODE2=rac2
      NODE2IP=192.168.1.222
      NODE2PRIV=rac2-priv
      NODE2PRIVIP=10.10.10.222
      NODE2VIP=rac2-vip
      NODE2VIPIP=192.168.1.224

      # Common data
      PUBADAP=eth0
      PUBMASK=255.255.255.0
      PUBGW=192.168.1.1
      PRIVADAP=eth1
      PRIVMASK=255.255.255.0
      RACCLUSTERNAME=rac1-cluster
      DOMAINNAME=localdomain
      DNSIP=
      # Device used to transfer network information to second node
      # in interview mode
      NETCONFIG_DEV=/dev/xvdc
      # 11gR2 specific data
      SCANNAME=rac1-scan
      SCANIP=192.168.1.225

      Any clues where to look would be appreciated.
        • 1. Re: Oracle VM Server 3.1.1 RAC Templates
          Sebastian Solbach -Dba Community-Oracle
          Hi,

          this is probably more a question for the VM forum, since this is not a RAC or RAC template connected error/error message, but clearly from OVM manager.

          However (from my OVM experiance) it looks like an error in the "hotplug" scripts when connecting xvdb resp.

          file:/OVS/Repositories/0004fb000003000013735cc530189395/VirtualDisks/0004fb0000120000d3f9422fae0baf39.img

          So either there is a problem accessing the file, or you server has a general problem. I might remeber seeing an actual update to OVM manager and OVM server yesterday having fixed a but in this regard. So best would be to update your servers.

          A reboot of the VM server will also probably solve the error - but this might only be temporarily.

          Regards
          Sebastian