8 Replies Latest reply: Aug 3, 2012 4:36 AM by pbell RSS

    SSO not working for one user in oracle apex

    894802
      Hi,

      I have an oracle apex solution which uses SSO to authenticate users.
      The application is working fine except for one user. The user is not able log into the application using his SSO. However, his SSO is working fine for other oracle apps like ARIA, Beehive central etc.

      Could you please help me in resolving this problem.... its really urgent.

      Thanks a lot for your help.
      Sanjay
        • 1. Re: SSO not working for one user in oracle apex
          pbell
          I am a bit cnfused here - does htis APEX app interact with BeehiveOnline and the user is having issues? What is the problem and how is it reproduced?

          Phil
          • 2. Re: SSO not working for one user in oracle apex
            894802
            Hi Phil,

            Thanks for your reply.

            No, the Apex app doesn't interact with any other app mentioned in my previous post. We just asked the user to check his SSO on the other apps to make sure if his SSO is actually working. The user is able to log into other apps with his SSO but he is not able to log into the Apex app.

            Hope you got what i am trying to say.

            Thanks again for your help.

            Sanjay
            • 3. Re: SSO not working for one user in oracle apex
              pbell
              Sanjay,

              The only APEX app I support is the group creation app for BeehiveOnline - if this is the one with the issue then I will be glad to help - if not maybe the APEX forums would be able to help a bit more.

              If it is my app then there is a restriction that only Oracle employes/staff can access it - we use the internal SSO to control this - BeehiveOnline is using the external SSO so is accessible to outside users.

              Phil
              • 4. Re: SSO not working for one user in oracle apex
                894802
                Phil,

                My app is also for only oracle employee/contractors.
                And i think Oracle Apex uses internal SSO to authenticate users..... but then the question is AIRA is also developed in oracle apex and uses SSO for athentication. The user in question is able to log into his ARIA profile and edit it but the same SSO is not working in our app. He gets Invalid Login error message.

                Its a strange issue beacuse all other oracle employees are able to access this app, only this user is facing this issue.

                Any help is appreciated.

                Phil, thanks for your help once again.

                Sanjay
                • 5. Re: SSO not working for one user in oracle apex
                  pbell
                  Ah, OK.

                  Wello if ther is an issue with the user accessing yiur system then you should probably raise an internal SR with the Directory Services team to investigate as I assume they gave tyou the partnber App registration configuration files.

                  One this we have found with some users is their tokens in the OID which are generated as they set their password can be missing for certain protocols - webDAV is particularly prone to this. Get the user to reset their password with APS and try again.

                  Phil
                  • 6. Re: SSO not working for one user in oracle apex
                    894802
                    Phil,

                    I have already raised an SR. The SR was raised almost 10 days ago but i didn't get any response from them.

                    The user did reset his password with APS but again he got the same result.

                    Thanks,
                    Sanjay
                    • 7. Re: SSO not working for one user in oracle apex
                      894802
                      Another update on the same issue.

                      We created a test app on the same server where our original app is hosted and the user was not able to log into this test app as well, but when we created a test app on a different server the user was able to log into the test app. It seems that his SSO is working fine.

                      Does it mean there is something wrong in the server which is causing this problem?

                      Does anybody has any idea on this?

                      Thanks,
                      Sanjay
                      • 8. Re: SSO not working for one user in oracle apex
                        pbell
                        Sanjay,

                        I wnat to hep resolve the issue but this is not something I can help with and is probably better posted into the identity management forum Identity Manager or the APEX forum Oracle Application Express (APEX) as this is more like;y to hit the audience that can help.

                        Phil