8 Replies Latest reply: Aug 5, 2012 4:10 AM by 437800 RSS

    report server error 11gR2


      Im have problems to start my report server which installed in windos 2008 R1.
      After installation works fine.

      Heres the log file of the console log of my report server

      12/04/18 17:54:18 Start process
      OpmnIntegrator: Register Ping callback.
      Apr 18, 2012 5:55:49 PM oracle.ons.CallBackSubscriber handleNotification
      INFO: OpmnIntegrator registration succeeded.
      Apr 18, 2012 5:55:49 PM oracle.as.management.opmn.integrator.OpmnIntegrator start
      INFO: Start the thread for component rptsvr_application_frminst to send periodic PROC_READY
      Apr 18, 2012 5:55:50 PM oracle.ons.CallBackSubscriber handleNotification
      INFO: dmsPublisher registration succeeded.
      OpmnIntegrator: Shutdown ...
      Stop process

      12/08/02 14:57:17 Start process
      Aug 2, 2012 2:57:18 PM oracle.security.jps.internal.credstore.ssp.CsfWalletManager openWallet
      WARNING: Opening of wallet based credential store failed. Reason java.io.IOException: PKI-02002: Unable to open the wallet. Check password.
      There's no way i can start the report server.

      Any Help?

      Thank you.
        • 1. Re: report server error 11gR2

          Oracle Reports by itself does not need a wallet. If Oracle Reports is integrated with SSO (that needs OID) or other security option like JAZN, those other layers need security wallet.

          If no such security is used (SSO/OID/JAZN), you can completely disable the security tag in rwserver.conf. For example, like this:

          <!--security id="rwJaznSec" class="oracle.reports.server.RWJAZNSecurity"/-->

          ("!--" is added at the beginning and "--" at the end).

          For Reports version (and later), the location of rwserver.conf is:

          ORACLE_INSTANCE/config/ReportsServerComponent/<repservername> in case Standalone Reports Server is used;
          DOMAIN_HOME/config/fmwconfig/servers/WLS_REPORTS/applications/reports_11. in case In-Process Reports Server.

          To determine the location of rwserver.conf in other Reports versions please reference:

          note:1083666.1 - Location Of Different Reports Configuration Files in Fusion Middleware Forms and Reports 11g Installations

          After changing rwserver.conf, please remember to restart the stand alone reports server for change to take effect, for the in-process reports server the restart of WLS_REPORTS is nwneeded.

          You may also want to check another possible cause of the issue:
          Error PKI-02002: Unable to open the wallet. Check password When Starting a Reports Server (Doc ID 1316651.1)


          If someone's answer is helpful or correct, please mark it accordingly.
          • 2. Re: report server error 11gR2
            Thank you for your reply.

            The report server now its working but i have prolem when im calling it from forms.

            REP-52251: The output of job ID 12 requested on Sat Aug 04 13:11:55 AST 2012 cannot be retrieved.<P>REP-56033: Job 12 does not exist.

            Im using the port 8888 both forms&reports ohs1 i think this is the http server
            Forms is ok.

            Both forms & reports SSO was default to no after installation. Never installed another application just WLS_FORMS & WLS_REPORTS.

            here's my code in when button pressed trigger.

            v_rep VARCHAR2(100);
            v_report_server VARCHAR2 (100) := 'RptSvr_APPLICATION_FrmInst';
            v_report_name VARCHAR2(100);
            v_format VARCHAR2(12) := 'PDF'; -- PDF or SPREADSHEET
            --v_format VARCHAR2(12) := 'SPREADSHEET';
            --v_format VARCHAR2(12) := 'htmlcss';

            repid REPORT_OBJECT;
            rep_status VARCHAR2(100);

            v_ip varchar2(100) := 'application:8888';

            v_report_name := 'report1';
            repid := find_report_object('report5');

            --SET_REPORT_OBJECT_PROPERTY(repid,REPORT_OTHER,'paramform=no p_1='||:SP_USERCODE);
            v_rep := RUN_REPORT_OBJECT(repid);
            rep_status := REPORT_OBJECT_STATUS(v_rep);
            WHILE rep_status in ('RUNNING','OPENING_REPORT','ENQUEUED')
            rep_status := report_object_status(v_rep);
            END LOOP;
            IF rep_status = 'FINISHED' THEN

            message('Error when running report - '||rep_status);
            END IF;


            I dont know how to indent the code... hope you can understand it.
            This code works in 10g.
            • 3. Re: report server error 11gR2

              Take a look into reports jobs repository http://server:8888/reports/rwservlet/showjobs there you will see all the reports you have run with associated error messages if applicable. Also you may take a look into reports log.

              Best regards
              • 4. Re: report server error 11gR2

                I tried to look out but i cant see any jobs queue

                Reports Server Queue Status

                Security Mode Non-secure Queue on server rep_wls_reports_application_frminst, on Sat Aug 04 21:39:28 AST 2012 To kill a current (enqueued or scheduled) job, click on the status icon for the specific job. Then click on Cancel Job button in next page.To get a cached output of a successfully finished past job, click on the Job Name hyperlink of that job (if available)


                View Current JobsPast JobsScheduled Jobs


                Previous Next

                Job ID Master JobID Job Type Job Name Job Status Job Owner Output Type Output Name Server Name Queued At Started At Finished At

                I dont know any work around now..

                Any help?
                • 5. Re: report server error 11gR2

                  It works now im found out that theres two report server.

                  1. rep_wls_reports_application_frminst
                  2. rptsvr_application_frminst

                  The rep_wls_reports_application_frminst report server is working now but i cant make with the other server which is has the shorcut in the programs
                  under Report Services

                  Start Report Server - rptsvr_application_frminst

                  I think rep_wls_reports_application_frminst is in process server.

                  How can make this rptsvr_application_frminst to the /reports/rwservlet ? properties instead of that rep_wls_reports_application_frminst.
                  • 6. Re: report server error 11gR2
                    have you started rptsvr_application_frminst through opmctl ?
                    • 7. Re: report server error 11gR2
                      Thank you for your reply

                      C:\Oracle\Middleware\FrmInst\bin>opmnctl startproc ias-component=RptSvr_APPLICATION_FrmInst
                      opmnctl startproc: starting opmn managed processes...

                      C:\Oracle\Middleware\FrmInst\bin>opmnctl status

                      Processes in Instance: FrmInst

                      ias-component | process-type | pid | status

                      emagent_FrmInst | EMAGENT | 1700 | Alive

                      RptSvr_APPLICATION_FrmInst | ReportsServerComp~ | 3404 | Alive

                      forms | FormsRuntime | 6036 | Alive

                      ohs1 | OHS | 5428 | Alive

                      Yes i tried thank you. its alive but i need to used rptsvr_application_frminst rather than the in-process server rep_wls_reports_application_frminst

                      The problem is i cannot bind it to rwserlet the rptsvr_application_frminst server.

                      Everytime i used this rptsvr_application_frminst server it always give the error
                      REP-52251: The output of job ID # requested on Sat Aug 04 13:11:55 AST 2012 cannot be retrieved.
                      REP-56033: Job ID# does not exist.

                      Can I change the rwservlet.properties located in





                      is there any configuration will affected if i will change?
                      • 8. Re: report server error 11gR2
                        Yes, you can change rwservlet.properties.

                        You need to bounce your reports server for the changes to take effect.