2 Replies Latest reply: Aug 8, 2012 9:37 AM by 954525 RSS

    11g Release 2 install missing packages


      I'm trying to install 11g Release 2 on a CentOS (4.9) box, but the pre-req check shows that I'm missing the following packages (I had 9 to begin):

      gcc-3.4.6 (X86_64)

      Tried to use the yum command "yum install gcc" but get the following error.
      Error: cannot find a valid baseurl for repo:update

      I think this is due to the "CentOS-Base.repo" file, which I've tried to update by changing the mirror URL's but no success.

      Then tried to find the rpms online (http://rpm.pbone.net/) managed to find the majority of them but I can't seem to find the 3 listed above. The new versions such as gcc-3.4.6-8.x86_64.rpm don't work, so I need the exact match.

      During the pre req I tried to select the "Ignore all" option and continue with the install but the installation fails with the following in /oraInventory/logs

      INFO: Start output from spawned process:
      INFO: ----------------------------------

      INFO: rm -f ntcontab.*

      +INFO: (if [ "compile" = "compile" ] ; then \+
      +/oracle/product/11.2.0/dbhome_2/bin/gennttab > ntcontab.c ;\+
      gcc -m64  -fPIC -c ntcontab.c ;\
      rm -f /oracle/product/11.2.0/dbhome_2/lib/ntcontab.o ;\
      mv ntcontab.o /oracle/product/11.2.0/dbhome_2/lib/ ;\

      INFO:           /usr/bin/ar rv /oracle/product/11.2.0/dbhome_2/lib/libn11.a /oracle/product/11.2.0/dbhome_2/lib/ntcontab.o ; fi)

      INFO: /bin/sh: gcc: command not found

      INFO: mv: cannot stat `ntcontab.o'
      INFO: : No such file or directory

      INFO: /usr/bin/ar: /oracle/product/11.2.0/dbhome_2/lib/ntcontab.o: No such file or directory

      +INFO: make: *** [ntcontab.o] Error 1+

      INFO: End output from spawned process.
      INFO: ----------------------------------
      INFO: Exception thrown from action: make
      Exception Name: MakefileException
      Exception String: Error in invoking target 'mkldflags ntcontab.o nnfgt.o' of makefile '/oracle/product/11.2.0/dbhome_2/network/lib/ins_net_client.mk'. See '/oraInventory/logs/installActions2012-08-06_04-50-51PM.log' for details.
      Exception Severity: 1

      Any help would me MUCH appreciated !