4 Replies Latest reply: Aug 9, 2012 9:12 AM by antexity1 RSS

    problem after upgrade 11.1.1.6 - "Invalid JSON String"

    user623575
      Dear All,

      after upgrade OBIEE to 11.1.1.6 I'm receiving an error message: "Invalid JSON string: 0 {t:1}:" when I'm trying to populate Dashboards, Catalog or even Help option.
      I've check with firebug that POST data are send and in fact I'm getting all data in a background - server response is correct,
      but instead of getting a correct view I have "Invalid JSON string :0 {t:1}:" message. Message comes from res/b_mozilla/common.js file.
      Cache has been also cleared.
      Any ideas what went wrong?

      Thanks'
      Regards.

      Edited by: user623575 on Mar 29, 2012 1:13 AM
        • 1. Re: problem after upgrade 11.1.1.6 - "Invalid JSON String"
          AdamN
          Hi,

          I had this error but in my case cleared browser cache helped. So try again with clearing all browser cache.
          • 2. Re: problem after upgrade 11.1.1.6 - "Invalid JSON String"
            user248025
            Hi,

            The error message "Invalid JSON string: 0 {t:4}" due to your Analytics Application was not re-deployed properly and also sometimes your javascript is still 11.1.1.5 version catched.
            1) to resolve this issues can you please Clear the browser cache and re-load the page or log in to OBIEE.
            2)if its not working then try to Re-deploy the Analytics Application, using the file $Middleware_Home\Oracle_BI1\bifoundation\jee\analytics.ear

            know Bug Ref:
            This is a known bug in OBIEE 11.1.1.6.0
            BUG:13845528 - UPGRADING TO 11.1.1.6, ANALYTICS DOES NOT WORK IN FIREFOX 10.0.2 ON WINDOWS 7 PC

            Please refer the below doc
            OBIEE 11g: Error: "Invalid JSON string: 0 {t:4}" Logging into OBIEE 11.1.1.6.0 after Upgrade [ID 1439063.1]

            Thanks
            Deva
            • 3. Re: problem after upgrade 11.1.1.6 - "Invalid JSON String"
              Dhar
              Hi,

              After upgrade to .6.2, I see this issue popping up, though there have been no issues with the catalog. I understand (and kind of googled) that this is a known issue with Firefox 10+ with BI .6.1+ (I do not remember with .6 if there was some issue). I am looking forward for a logged bug for this case.
              Hope this helps.

              Thank you,
              Dhar
              • 4. Re: problem after upgrade 11.1.1.6 - "Invalid JSON String"
                antexity1
                Oracle support stated to try the following:

                - Add OBIEE to trusted sites and then remove it - Didn't Work
                - Redeploy analytics.ear - Didn't Work
                - Clear Browser Cache - Didn't Work

                Fix that worked for us:

                IE9:

                Goto the Internet options and the Advanced Tab and reset to factory defaults. That worked. Both ports 7001 and 9704

                Firefox 14:

                Restored to factory defaults did not work (Holding the shift key while starting firefox)

                - I removed and then reinstalled Firefox and then it worked, only for port 7001. Not sure why.


                Ultimately this is a client issue, and nice thing is that we have OBIEE only in development, therefore we dont have to ask the business to perform the following changes.

                Hope this helps someone out.