1 Reply Latest reply on Aug 20, 2012 3:03 PM by 956714

    Cannot uninstall Java JRE 1.7 32bits

      For some reason my firefox browser stopped detecting java and now I can't run anything with java on it because it says that it's not installed, so I went to add/remove programs and tried to uninstall java but it just won't get removed.


      So when I try to uninstall it (Java(TM) 7 Update 5) a little window appears with a progress bar, after it completes it disappears but Java is still there..

      this is the window that appears: http://rcupload.com/images/HLUwZ.png

      Here's what I tried to do:

      1) Use CCleaner to uninstall it: - I choose the program, press uninstall and it disappears, but when I refresh the list it will still be there. I also tried using the "remove entry" button in CCleaner and i just get a message saying "cannot delete msi installer'.

      2) I tried using JavaRA: - I ran it as administrator, clicked "remove older versions", and I got the message that Java JDK 1.7 was uninstalled and all the files, but now I see that there is no folder for it at "C:\program files (x86)\Java\" (there was one inside before, called something like jre-7) and the icon in the installed programs appears like a white box instead of looking the like the java logo.

      3) I tried downloading java and installing it: - I run it, it downloads and it gets to a screen where it asks me if I want to install a toolbar, I click next and I get this message: http://rcupload.com/images/xiCIu.png

      I also tried changing the destination folder. same result.

      -- Resumed: I need to get rid of Java(TM) 7 Update 5 but the uninstaller seems not to work and files are missing.

      Any help will be appreciated!

        • 1. Re: Cannot uninstall Java JRE 1.7 32bits
          Hi - using the Microsoft fix-it tool available here, running as administrator, did the trick for me: http://support.microsoft.com/mats/Program_Install_and_Uninstall

          I selected the options that allowed me to manually choose which program to uninstall...then I was able to re-install java from the Oracle Java 7 download/installer.

          Good luck!