5 Replies Latest reply on Oct 21, 2012 11:40 AM by user12068228

    Bad Performance in editing big pivot tables

      We are successfully running a new obiee BP1 installation.
      Sometimes the performance of the ui in the Internet Explorer ist very slow. Especially when working with the fusion middleware control or editing big pivot tables (that means more than 20 measures) the response time from the ui is not almost unbearable.
      I've read about enabling http compression to solve that but I'm not sure if that's also applicable when working without a separate http server.
      Do you observe the same problems? has anyone a solution for that.
      Thank you
        • 1. Re: Bad Performance in editing big pivot tables
          Hi User,

          Yes , obiee 11g performance is poor in IE. Compression could solve the issue to some extend. Did you try in Firefox?

          • 2. Re: Bad Performance in editing big pivot tables
            Amith Y
            You can also try following the MS KB Links below to tune Internet Explorer for better performance. Below is extracted from a white paper on 11g performance tuning.

            “How to optimize Internet Explorer” > http://support.microsoft.com/kb/936213
            “IE to download more than two files at one time” > http://support.microsoft.com/kb/282402
            “IE slow performance or frequent freeze” > http://support.microsoft.com/kb/555942
            “Tune IE timeout values” > http://support.microsoft.com/kb/813827
            In the IE browser navigate to: Tools -> Internet Options -> Advances -> Security and Locate the “Enable native XMLHTTP support” option and check the check box.
            • 3. Re: Bad Performance in editing big pivot tables

              As Deepika and Amith said, there have been some turnaround time issues with IE. However, I feel Pivots are often the victims of performance problems and here are some of my ways of dealing with them

              1. Edit Pivot always with best filters in place. I would say, apply all the dashboard prompts for this report while editing pivots.

              2. BI Server as you know gets a temporary dataset to operate on during analysis editing, tuning some of the BI Server parameters like VIRTUAL_TABLE_PAGE_SIZE might also help here.

              3. Having a resonable timeout minutes in the instanceconfig.xml might also help, just to let the temporary result set be present to be operated on.

              4. Sometimes, tuning the browser also might help as in increasing the disk space to use, 'Temporary Internet files ->Newer version of pages' option etc.

              Hope this helps.

              Thank you,
              • 4. Re: Bad Performance in editing big pivot tables
                Thank you all for your suggestions. Changing the IE configuration is not that easy because in companies everything is controlled by policies which I can't change that easy.
                I disabled preview so I guess the performance problem is not due to insufficient filters or not enough memory to store temporary data.
                I guess I will have to see if I can get a firefox installation to test the behaviour...
                • 5. Re: Bad Performance in editing big pivot tables
                  Has anybody experience with OHS?
                  is that a recommended practice?