This discussion is archived
1 Reply Latest reply: Aug 23, 2012 10:19 PM by 851852 RSS

MessageQ for RHEL5

956357 Newbie
Currently Being Moderated
Hi, we are investigating the possibility to migrate our OpenVMS Alpha applications to RHEL5. These applications rely heavily on the use of BMQ, so we want to use Oracle MessageQ on RHEL5 too.

We have downloaded MessageQ from edelivery.oracle.com but this appears to be suited for RHEL6.1 only. Starting a group and connecting it to another group on an Alpha-system is no problem, but linking with the shared object libraries in /opt/messageq/lib leads to the following error:
/usr/bin/ld: skipping incompatible /opt/messageq/lib/libpams.so when searching for -lpams

However in the document "Oracle MessageQ Certified Platforms" from March 2012, RHEL5 is mentioned as a supported platform for MessageQ and RHEL6.1 is not. Could someone explain this to us?

Edited by: 953354 on 17-aug-2012 6:54
  • 1. Re: MessageQ for RHEL5
    851852 Newbie
    Currently Being Moderated
    We did certify the OMQ to RHEL 5.0, but the certified binary is not for RHEL6.1, you should use the binary for SUSE Linux on RHEL 5.0, you can download it (Download for Suse for Linux x86 (3,364,784 bytes) ) from http://www.oracle.com/technetwork/middleware/tuxedo/downloads/index.html.

    Regards,
    /Lingtao

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points