4 Replies Latest reply: Sep 7, 2012 4:33 AM by 956363 RSS

    ROracle installation R-2.5.1 and ROracle_1.1-4.tar.gz

    956363
      Dear,

      I have R version 2.5.1 running on windows Vista
      sessionInfo()
      R version 2.15.1 (2012-06-22)
      Platform: i386-pc-mingw32/i386 (32-bit)

      locale:
      [1] LC_COLLATE=English_United Kingdom.1252
      [2] LC_CTYPE=English_United Kingdom.1252
      [3] LC_MONETARY=English_United Kingdom.1252
      [4] LC_NUMERIC=C
      [5] LC_TIME=English_United Kingdom.1252

      attached base packages:
      [1] stats graphics grDevices utils datasets methods base

      loaded via a namespace (and not attached):
      [1] tools_2.15.1

      In order to install ROracle I did the following:
      - installed RTools (Rtools215.exe)
      - made sure RTools is in the PATH
      - installed DBI: R CMD INSTALL DBI_0.2-5.tar.gz
      - installed the instantclient basic and sdk (version 11.2.0.1.0) by extracting it at C:\instantclient\i386\instantclient_11_2
      - ran R CMD INSTALL --build ROracle_1.1-4.tar.gz
      This does not work.
      I get the following error popup when 'testing if the installed package can be loaded':
      Entry point not found

      The procedure entry point OCIArrayDescriptorAlloc could not be located in the dynamic link library OCI.DLL.

      Strangely enough running
      R CMD INSTALL --build ROracle_1.1-2.tar.gz
      did work.
      Version 1.1.3 (R CMD INSTALL --build ROracle_1.1-2.tar.gz) did not work either - same OCIArrayDescriptorAlloc  error.

      Can someone help here? I'm particularly keen in seeing if "Date time" support in version 1.1-4 now works.

      thanks,
      Jan