3 Replies Latest reply: Aug 17, 2012 7:23 PM by Steve.Clamage-Oracle RSS

    Installation of Solaris Studio 12.3 crashes on Mandriva 2010.2 Linux distro

    eldiener
      Attempting to install Solaris Studio 12.3 on Mandriva Linux 2010.2 I get this crash:

      "Installing native package...
      [2012-08-11 06:48:48.614]: java.lang.NullPointerException
      [2012-08-11 06:48:48.614]:      at org.netbeans.installer.product.components.NativeClusterConfigurationLogic.getSPROsslnkInstalled(NativeClusterConfigurationLogic.java:110)
      [2012-08-11 06:48:48.614]:      at org.netbeans.installer.product.components.NativeClusterConfigurationLogic.install(NativeClusterConfigurationLogic.java:136)
      [2012-08-11 06:48:48.614]:      at org.netbeans.installer.product.components.Product.install(Product.java:374)
      [2012-08-11 06:48:48.615]:      at org.netbeans.installer.wizard.components.actions.sunstudio.InstallAction.execute(InstallAction.java:167)
      [2012-08-11 06:48:48.615]:      at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)"

      Has anyone experienced this problem before and know the reason and a potential workaround ?

      I realize that Solaris Studio 12.3 does not say that it supports Mandriva Linux, but this is a pretty recent distro and I would think it should install on it.
        • 1. Re: Installation of Solaris Studio 12.3 crashes on Mandriva 2010.2 Linux distro
          Steve.Clamage-Oracle
          Studio is supported only on Oracle Linux 5 and 6, and Red Hat Enterprise Linux 5 and 6, as discussed in the release notes.
          http://docs.oracle.com/cd/E24457_01/html/E21986/ossrn.html#scrolltoc
          The installer is unlikely to work on other Linux distros, but you can try the tarball instead. On unsupported distros you get variable results, from mostly working to mostly not working, due to the wide variation in details that Studio cares about.
          • 2. Re: Installation of Solaris Studio 12.3 crashes on Mandriva 2010.2 Linux distro
            eldiener
            I was able to install Solaris Studio, using the installer, on CentOS 5.8, Fedora 17, and Suse 11.4. I am sure that Mandriva 2010.2 is more recent in nearly everything than CentOS 5.8 so it seems it should work there. Clearly RHEL 5 is pretty old also ( CentOS 5.x is just an upstream version of RHEL 5 ) and as you quote it is supposed to install there. Nonetheless I will just manually try the tarball instead. The installer should give some indication of why it fails for a given distro.
            • 3. Re: Installation of Solaris Studio 12.3 crashes on Mandriva 2010.2 Linux distro
              Steve.Clamage-Oracle
              Trying a more recent version of Linux than any supported version pretty much guarantees that the Studio installer, and possibly Studio components won't work. :-) New Linux versions typically have incompatible changes in public interfaces that the installer and components rely on. For example, when we moved from supporting RHEL/OEL 5 to RHEL/OL 6, we had to do months of work to get all of Studio working.

              It's unlikely that the installer could make a diagnosis helpful to you when it fails on an incompatible Linux version. Most likely, some system call or system library routine changed, resulting in bizarre program behavior. At best, the installer could report an internal failure, which would be helpful to the programmers who develop the installer, but not helpful to anyone else. The installer could verify that it is running on a supported Linux version and abort if not, but most people would not like that solution.

              We document the platforms that are supported. We don't expect Studio to work elsewhere, but you are free to try it and see what happens. The most critical compatibility issue is the underlying Linux kernel version. If that version is close enough to the supported versions, there is a good chance Studio will work reasonably well.