This discussion is archived
3 Replies Latest reply: Aug 21, 2012 4:58 AM by UW (Germany) RSS

Suggestion for forum improvement

UW (Germany) Explorer
Currently Being Moderated
Recently, when I tried to execute some code at home which I had posted in this forum at work I noticed that it did not work and trying to find out, what happened I saw that two code lines like
field1||' < '||field2,
field3||', '||field4||'('||field5||')',
were shortened to a single line
field1||' < ', '||field4||'('||field5||')',
and some days later I had an example where several line of code disappeared after a &lt; sign and I noticed that also other user of the forum posted code that was somehow "broken" because they used characters like &lt; and &gt;. I think this happens because the forum software tries to find html tags in the code, but in my opinion this it not always a good idea. If I copy and paste some code from my "real world" here, it is annoying to check, whether there occurs a problem because of the html interpretation of some characters in this code.

A possible solution for this could be, that there is a setting in the user profile like "I want to use html tags in my postings" and in my opinion this should be switched off as a default for new users of the forum. And if this setting is not checked any code in a posting will be shown exactly as it was pasted into the box.

What do you think about my idea?
  • 1. Re: Suggestion for forum improvement
    jgarry Guru
    Currently Being Moderated
    I love using html, and tend to totally abuse it when I can, especially images. :p

    You might look around at some of the older discussions here. This is old jive software, and some features have been removed due to performance issues. It's supposed to all be replaced sometime, so hopefully suggestions for improvement will be considered. The worst, in my honest opinion, would be if they made it work like Facebook.
  • 2. Re: Suggestion for forum improvement
    BluShadow Guru Moderator
    Currently Being Moderated
    UW (Germany) wrote:
    A possible solution for this could be, that there is a setting in the user profile like "I want to use html tags in my postings" and in my opinion this should be switched off as a default for new users of the forum.
    And when are these new users supposed to be allowed to switch it on?

    html tags in posts can lead to major spam abuse or malicious code. I think that's why it was disabled (as we had some abusing members posting threads that automatically redirected to dodgy sites)

    As already mentioned, the jive software is old and unsupported now, so Oracle are already looking to upgrade to a new forum.
  • 3. Re: Suggestion for forum improvement
    UW (Germany) Explorer
    Currently Being Moderated
    I don't know what was disabled in the past but I still can use things like &lt;font color="red"&gt;<font color="red">red</font>&lt;/font&gt; here in the forum and that's what I mean.

    And maybe you misunderstood my intention. I don't want more html as there is today. I want less, at least for unexperienced users. If users want they can switch it on immediately but than they should know what they do and be aware of the side effects.

    I personally would prefer to keep html off totally. I don't need the possibility to use <font color="red">red code</font> but I would like to copy and paste my SQL and PLS/SQL code without checking if there are any characters in my code which get interpreted as html code and destroy the functionality of the code.