2 Replies Latest reply on Aug 21, 2012 10:16 AM by 948372

    It seems that cache agent stop working.. any idea?

      Hi teachers,

      I got a global cache group, and I had loaded data into it.

      Now I need to refresh the cache group with new data. I did like this (since refresh cache group is not supported for global cache group):
      1. unload cache group xxx; [works well]
      2. load cache group xxx where ... commit every 10000 rows; [works BAD]

      Then, I tried to load the previous data into cache group, also the data cannot be loaded again.

      There is no error message printed, and I cannot stop the "load cache group" command in ttisql, I need to use "pidof ttIsqlCmd" to get the pid and kill it.

      So, I want to restart the entire ttdaemonadmin process, when I tried to call ttcachestop after detaching the node from grid, the command hangs there again.

      I ignored this and then I tried this:
      [tta@xingyong70 bin]$ ./ttdaemonadmin -stop
      ttDaemonAdmin: timed out waiting for daemon to go away.
      Daemon process 11461 is still running.

      Seems that I also cannot stop the daemon, the user "tta" is the one I installed TimesTen with.

      So, I login as root, and get the pid of ttdaemonadmin by issuing "netstat -lnp", and tried to kill 11461 with " kill 11461", but the process is still there.

      I can only kill it by "kill -9 11461".


      After I restarted the ttdaemonadmin, I can successfully load the cache group.

      I want to know what caused the "load cache group " command and "call ttcachestop" command hangs there. Or any possible incorrect actions may cause that.

      Thanks in advance!
        • 1. Re: It seems that cache agent stop working.. any idea?

          How many rows you are trying to load using LOAD CACHEGROUP command ? Did you checked the daemon logs to see any error/issues being reported there?

          What version of Timesten is this ?
          Can you try PARALLEL clause at the time of loading . Something like below

          LOAD CACHE GROUP [Owner.]GroupName WHERE [condition] COMMIT EVERY 1000 ROWS PARALLEL 4;

          • 2. Re: It seems that cache agent stop working.. any idea?
            Hi Rajesh,

            Thanks for the response.

            I was trying to load 5 million records into TT. I had loaded that quantity of records successfully earlier today. My RAM is enough.

            My TimesTen version is 11.2.2.

            I cannot reproduce this issue now since I have loaded 10 millions records into TT just now, I will pay attention to it continuously.

            Thanks again,

            Edited by: 945369 on 2012-8-21 上午3:13