6 Replies Latest reply on Aug 22, 2012 2:24 PM by 929656

    Upload Fragment library fails

      I have a zip file containing the fragment definition. I am trying to upload the zip file using site studio. I am getting an error that says
      Failed to check in file ".....xml". (Unable to upload data. Unable to open file "....xml". Error: "......xml" was not found.)

      I unzipped the zip file and found the xml file within it. Can someone help me figure out what is going wrong?


      Edited by: 926653 on Aug 21, 2012 8:51 AM
        • 1. Re: Upload Fragment library fails
          ryan sullivan2
          Did you download that zip from site studio? The correct structure of a fragment is a native xml file and the alternate file is a zip. If you only take the alternate file, then you won't have the required xml.

          I believe that the download from Site Studio will be a zip file which contains everything required.

          I tend to use the archiver for moving fragments to ensure that the content item is moved intact.

          • 2. Re: Upload Fragment library fails
            I have a zip file which seems like it was created through a download. To upload this fragment library to my content server, I am doing these steps in Site Studio

            1) File -> Fragments -> Upload Fragment Library
            2) In the dialog box, I am choosing the zip file. I then get this error.

            I tried extracting the zip file and I chose the extracted xml, I got this error -
            "The file that you are trying to Upload is not in the correct format.

            Please ensure that you select a fragment library zip file that was created by an earlier download. Downloaded library files contain the fragment library description in an XML file as well as all the assets for all of the fragments in the library.".

            Since I have the downloaded Site Studio zip file, what steps should I follow to get the fragment uploaded to my content server?
            • 3. Re: Upload Fragment library fails
              ryan sullivan2
              this points back to the details in my original post.

              You mention "I have a zip file which +seems+ like it was created through a download", then you also say "Since I have the downloaded Site Studio zip file...".. You must be certain of where the zip came from. if it did come from site studio, then it should work w/o issue. Since it's not working, I'd assume you either did not get it from site studio's fragment download or it's been corrupted.

              Have you opened the zip to check it's contents?

              when you open the zip do you see a xml file or do you only see a folder(s) that are named the same as the fragment(s)? Remember that fragments are packaged into a fragment library. the zip file will be the entire fragment library.

              This seems to be a case of the error being the most likely culprit and it should be the first thing on your troubleshooting list.

              Let us know what you find.

              • 4. Re: Upload Fragment library fails
                I copied the zip file to a folder and tried unzipping it. I got an xml (in the same folder as the zip file) and two folders - both of these folders contain images.

                I am still getting the same error. Do you have any other suggestions?
                • 5. Re: Upload Fragment library fails
                  ryan sullivan2
                  Sounds like the correct format. Have you tried to re-zip it and see if that new zip works? perhaps something happened to the other zip file during copy or email or something?

                  Also, you could try to download an existing frag lib from the target site studio env and check if you can see any differences in the formats.
                  Try to re-upload the test zip that you just downloaded from the above example. see if it works in a simple control test where the zip came from the same env.

                  You can also check the logs of the content server & designer to see if anything else is in there. Perhaps your user doesn't have access to the target account and/or security group? You can test this by trying with your weblogic admin user.

                  if you have access to the source environment, I'd try to export the item via archiver and manually move the archive to the new environment and import, again, via archiver.

                  Lastly, you can try to manually check in the content item by setting all of the metadata exactly the same as the source environment, then set the native file to the .xml file & zip up only the folders w/o the .xml and check in that zip as the alternative file. I would not recommend this approach, but it could be used as a plan C or D.

                  Let us know if you get anywhere!

                  • 6. Re: Upload Fragment library fails
                    The thing that worked for me is -

                    1) Go to content server home page. Choose New Check-in
                    2) In my local machine, extract just the xml file out of zip file. So, now we have xml as a separate file and all others in the zip file. Delete the xml from the zip file.
                    3) In the New Check In form, chose the xml as primary file and the zip file as the alternate file. Set "Web Site Object Type" field to "Fragment". Enter Content ID and Title as you wish and click "Check In" button.

                    Thanks, Ryan.