1 Reply Latest reply: Aug 24, 2012 2:52 PM by Rogerl-Oracle RSS

    Oracle web12 java 1.6.32

    957856
      I am running into an issue when trying to run Oracle R12, i am getting an error that the wrong version of Jinitiator is installed.

      We have been told by oracle support that in order to use oracle 12 we must use either Java 1.6.32 or 1.6.33, we also must have java 1.7.x installed for another application.
      some of the machines that are set up are receiving a prompt when logging into the Oracle 12 web interface to select the version of java to run, on these machine there is no problem as long as we select Java 1.6.32, but on other machines with the same setup we do not receive any prompt to select the appropriate java version and just receive an error that the wrong version of the Jinitiator is installed.

      All of the machines being used are the same specs.
      Lenovo M91p
      Win 7 Enterprise
      4gb ram
      Java 1.6.32
      Java 1.7.5
      IE9

      Any help is appreciated.

      Thank you.
        • 1. Re: Oracle web12 java 1.6.32
          Rogerl-Oracle
          Hi,

          The cause is that the applet is running with Java 7 installation. The applet does not read the version number correctly and believes that it is running with Jinitiator, and the wrong version at that. The version of Java that is used by the applet is determined by the installation order. Install 7 last and the applet is going to run with 7.

          I am not sure if that is something you can configure with R12. You can make changes in the Java Control Panel that will affect which JRE is used. The 7 plugin can run the 6 JRE. See:
          http://docs.oracle.com/javase/6/docs/technotes/guides/jweb/applet/applet_dev_guide.html
          http://docs.oracle.com/javase/6/docs/technotes/guides/jweb/applet/plugin_config.html

          -Roger